RPGWatch Forums

RPGWatch Forums (http://www.rpgwatch.com/forums/index.php)
-   Divinity 2 (http://www.rpgwatch.com/forums/forumdisplay.php?f=40)
-   -   Inexplicable Lag (http://www.rpgwatch.com/forums/showthread.php?t=10006)

ToddMcF2002 March 1st, 2010 01:12

Inexplicable Lag
 
Game will run great 1 minute and then plunge into single digit FPS. I'll just be standing there doing nothing and it will go from 30 to 10 or less.

Anyone else? I've hunted various forums to no avail. P8400 @ 2.26 with 4GB. Vista 64. 9800m GTS 1 GB.

Corwin March 1st, 2010 01:20

Do you have something else running in the background? It never happened to me on XP 64.

ToddMcF2002 March 1st, 2010 02:07

Nothing significant. I updated my drivers but it really didn't do anything. When the framerate plummets I can run away for a few seconds and come back to the same scene and it will be fine. Then it will drop again, no rhyme or reason. Pretty frustrating.

Acleacius March 1st, 2010 02:08

Even though I patched mine to 1.3, have several of the standard bugs that seem to be going around like the skipping movies. Framerates take a dive when Larian starts using their partical effects as in fog or Black Bear.

What the heck did they use for the UI some kind of java with no memory flush/allocation. :p

They offer no apparent way to really tweak their effects either with an ini file, the game is playable. Still after two or three patches, it's a bad design to not have an ini file accessible when you need to release your game early because your an independent.

No active console to help either, guess there is no hope of getting an editor to let fans work on the game, bah! ;)

ToddMcF2002 March 1st, 2010 03:22

Well its not graphics related as far as I can see. I dropped down to low settings (50-60 FPS) and it will drop to 12 while I'm standing still. After about 20 seconds it speeds back up.

I'm thinking that for my pc the game is just borked. I don't have problems with any other game. I'm on patch 1.3 now as well.

Gorath March 1st, 2010 04:52

Did you link the game to one CPU core, as suggested in the Larian forum?

ToddMcF2002 March 1st, 2010 05:49

I now think this is all a red herring. I ran a bunch of diagnostics on my laptop and I'm running 100 degrees Celsius under load for the 9800 and my CPU is Prime95 at 92 degrees Celsius. Good for frying eggs, not so good for running games. For whatever reason Divinity specifically seems to be exposing a heat issue on my laptop I did not notice playing Dead Space.

Time for some compressed air and some hope…

crpgnut March 1st, 2010 14:51

Ouch! Good luck Todd. If your CPU fan is locked up, it sucks to replace those on a laptop.

ToddMcF2002 March 1st, 2010 16:27

All is well. I bought a Tragus Chill Mat and some compressed air.

Vid card:
100c down to 65c under load. Divinity II lag issue has gone away.
CPU:
92c under Prime95 load down to 73c.

I think the compressed air did the most frankly. No big chunks of dust but lots of little particles came out.

Tweaks March 1st, 2010 16:37

i got the same probleme and my pc is better then his the only thing that is working for me right now is using prosses laso running every thing on 2 core and only the game on the other 2 and putting it priority up to real time highest!!

i dont sugest this if you dont have a 4core

ps my spec are
4core 3.0 ghz
285GTX
my monitor can go up to 120 refresh rate
and XP 64 cause it only uses 512 mb to run and vista take 1G

anyways that what i did

ToddMcF2002 March 4th, 2010 05:28

OK damnit I'm tired of these bizarre frame rate issues. Yes I had a heating problem but I solved it. I run GPU-z perpetually now and never exceed 80c.

I'm coming to the conclusion that game has serious CPU issues. Think about it: how on Earth can Divinity 2 on Gamebryo be a bigger hit than Fallout 3 on Gamebryo? Divinity clearly has less detail in the landscape and far less detail in the models than FO3.
I'll see Fraps at 15 FPS occasionally looking at a rock. I ALT+TAB and there it is, CPU pegged while my GPU is lumbering on in the 70c range. I can get a few FPS back by dropping settings but even that is erratic.

Anyway, its still playable but when its chugging along with FPS in the upper teens I'll be damned if I see anything in front of me to justify it. Gothic 3 had better framerates!

JDR13 March 4th, 2010 05:35

Which setting are you using? It runs great on my system on "High", but "Extreme", which pretty much looks the same as High to me, changes to a slideshow for some reason.

ToddMcF2002 March 4th, 2010 05:40

I'm on High but dropped shadows to medium. Around the Lovis tower area I'm dropping as low as 18 FPS. The game just does not have the graphics to justify that, especially on this engine. I simply don't get it. Surprisingly 18 feels as smooth as the high 20's with this title but i think that is largely due to its very low quality animation frames. These enemies jerk around (and when they die its just painful to watch that goofy flip over planter move) even at 50 FPS.


All times are GMT +2. The time now is 18:43.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch