RPGWatch Forums

RPGWatch Forums (http://www.rpgwatch.com/forums/index.php)
-   Gothic 1/2 (http://www.rpgwatch.com/forums/forumdisplay.php?f=22)
-   -   Gothic 1 starting problems (not Nvidia related) (http://www.rpgwatch.com/forums/showthread.php?t=12449)

Lurking Grue January 26th, 2011 18:09

Gothic 1 starting problems (not Nvidia related)
 
Decided to install Gothic 1 again and give it a whirl on my new(ish) PC, but my plans hit a snag. The darn thing won't launch without a workaround trick and I decided to ask the esteemed people of the Watch if there could be a better solution to my dilemma. Note that, unlike many posters here with G1 problems, I do NOT have an Nvidia card nor 64-bit Win 7.

What I DO have is Win 7 32-bit and an ATI card. The game installs just fine to version 1.08j right out of the box (I tried 1.08k but it doesn't make any difference). When I try to launch it nothing happens. Program manager shows (under the second tab from the left) that there's a process called gothic.exe running but nothing's happening. I've got G1 set to run in XP compatibility mode and I'm running it as an administrator, but no deal.

The workaround I've found is that if I launch Gothic 1 twice (so I've got two gothic.exe's running), then open the manager and close rundll32.exe, one of the two gothic.exe's shuts down with it but the other launches and I'm able to play Gothic 1 just like I used to on my old PC (I miss the good ol' Win XP). Albeit, I get no intro videos (got sound, but no video). That's no biggie though as the game itself works OK. (I guess I need to disable video scaling to remedy the videos, but haven't gotten around to that yet.)

Has anyone got an idea how I could get G1 to work without that program manager juggling? Even if I can get G1 to run with the workaround, I'd appreciate any help on getting G1 to launch without this trick.

Wulf January 26th, 2011 23:51

…and your mainboard cpu is….?….:S

Lurking Grue January 27th, 2011 08:44

Quote:

Originally Posted by Wulf (Post 1061046637)
…and your mainboard cpu is….?….:S

Yes, I should've posted more thorough specs in my previous post. My bad. (Blame it on posting in a hurry from work. "I was working hard/hardly working…" ;))

I've got an Intel i7 860 quad core processor on ASUS P7P55D-E motherboard. My OS is Windows 7 Home Premium 32-bit and I've got an ATI 5850 graphics card.

I had a similar problem with Gothic 2 on this PC, but for G2 there's the fan-made Gothic Starter thingy that fixed this launching problem. Unfortunately I cannot find anything similar for G1.

I fiddled with Gothic 1 yesterday evening a bit, like disabling virus scanners and whatnot, but still couldn't get it to launch without that Task Manager trick. How come this "rundll32.exe" is blocking G1?

P.S. I got the videos to work by disabling video scaling, as I expected.

Wulf January 27th, 2011 14:25

I suspect you are running G1 on 1 core - not sure of the best correction method.

Gothic will run on 1 core of a dual core or multi core pc machine - but can possibly crash when the processor goes to high demand, windows control management cannot always cope correctly with sharing 'executions' across the cores - so one way or another they need to be "optimised" .
For example, i have an AMD dual core cpu and have installed the dual core optimiser - there's a nice explanation that goes……

The AMD Dual-Core Optimizer can help improve some PC gaming video performance by compensating for those applications that bypass the Windows API for timing by directly using the RDTSC (Read Time Stamp Counter) instruction. Applications that rely on RDTSC do not benefit from the logic in the operating system to properly account for the affect of power management mechanisms on the rate at which a processor core's Time Stamp Counter (TSC) is incremented. The AMD Dual-Core Optimizer helps to correct the resulting video performance effects or other incorrect timing effects that these applications may experience on dual-core processor systems, by periodically adjusting the core time-stamp-counters, so that they are synchronized.

*G1 is reliant on time stamp counting (RDTSC)* so ideally you would need to find a suitable optimiser software or fix specific to the Intel quad core cpu for your Asus mainboard, it would execute each time the pc is started and be 'invisible' in use. There are also some stand alone optimiser applications though i havn't tried them.

To see what your cores are doing, do your fiddly routine to get G1 running then 'ctrl-escape' to the desktop then 'ctrl-alt-del' into task manager and then observe the multi cpu cores performance graphs prior to any optimisation so you can compare later.

Even in optimised mode with all cores firing, one core always appears to be doing the main work while others are doing less or waiting for higher load demand as required.

Hope this helps a bit.

EDIT (added info) Not sure but you might try some tweeking.

Run 'msconfig' - then to boot options tab/advanced options (check 2 for 2 cores or 4 for four cores) in 'number of processers select tab might yield some results if it isn't set already - but have not tried this myself.

Lurking Grue February 4th, 2011 09:05

Quote:

Originally Posted by Wulf (Post 1061046738)
I suspect you are running G1 on 1 core - not sure of the best correction method.

Nah, I was running it with all cores. Everytime I tried to set the affinity, I got an error message.

Quote:

Originally Posted by Wulf (Post 1061046738)
The AMD Dual-Core Optimizer can help improve some PC gaming video performance by compensating for those applications that bypass the Windows API for timing by directly using the RDTSC (Read Time Stamp Counter) instruction. Applications thatů {snip}

Ehh, um, I will just nod my head like I was understanding what that was about. Yes. See, I'm listening. Uh, yeah. But where is the 'any' key? ;)

I'll try looking for some kind of optimizer, but I'm not sure if I'll start tweaking things that much. As I can get G1 to start with the gimmick I described and it works flawlessly once it starts, maybe I'll just endure those few extra steps for now.

Quote:

Originally Posted by Wulf (Post 1061046738)
Even in optimised mode with all cores firing, one core always appears to be doing the main work while others are doing less or waiting for higher load demand as required.

Yep, that's the case here too. With G1 running, one core is doing most of the of the work while the others seem to be basically idling.

Anyways, thanks for your help! I'll try fiddling with G1 a bit more to see if I can resolve this somehow. Fortunately, G1 does work, even if it needs a bit of coaxing.

Pladio February 7th, 2011 00:38

I haven't read the whole thread, so I don't know which version of windows you have but gog makes old games work apparently better. http://www.gog.com/en/gamecard/gothic


All times are GMT +2. The time now is 06:18.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch