RPGWatch Forums

RPGWatch Forums (http://www.rpgwatch.com/forums/index.php)
-   Xenus 2: White Gold (http://www.rpgwatch.com/forums/forumdisplay.php?f=44)
-   -   Negative acceleration ? (http://www.rpgwatch.com/forums/showthread.php?t=17705)

svartberg August 1st, 2012 13:50

Negative acceleration ?
 
Got the game, 1.1 patch + 1.6 unofficial, with sound fix & HUD optimization.
Always had negative acceleration (aka input lag, mouse smoothing, etc)

Anyone else encountered that ? are there any fixes ?

badmofo August 5th, 2012 13:15

I had this problem with precursors, not with white gold really though. I tried all sorts of things with precursors (which uses basically the same engine) but in the end only a CPU upgrade made any difference. An i5 did the trick for me, what hardware are you using?

Try turning down the settings and see if that makes any difference.

svartberg August 5th, 2012 13:41

I have a core 2 quad q9550, 8gb ram, with 560TI 1GB.
I hit around 30-40 FPS on first island, I tried changing settings to both low & high (including config tweaks) and did not see even a slight difference in negative acceleration.

But thanks for reply mate, is good to know this problem is not universal !
I actually suspect is my poor generic mouse with this particular game (no problems with other games), long due for an upgrade so will see if it helps ey.

svartberg August 8th, 2012 06:45

Ok here's an update, I have tried with 2 more mice.

CM Storm Spawn - exactly same negative acceleration, no acceleration in other games.

Logitech M90 - got positive acceleration in game, however I get positive acceleration in any other game as well.
Maybe it's the odd 1000DPI, but honestly I think it's just a crappy sensor.

Ok I have spend many hours now on this issue, even went out and bought some mice just to try - I pretty much have no idea why this is happening …
I'm leaning towards badmofo's explanation it's poor engine implementation (maybe deep shadows didn't even separate input to different threads)
I do notice it's not acceleration per se but more like input lag, if I move the mouse really really fast it barely moves at all ! (I guess that's what really annoys me)

I have finished boiling point several times and really enjoyed it, but there's simply no possible solution to this problem, maybe when I upgrade my pc I'll try it again, who knows.

svartberg November 23rd, 2014 02:41

Ok got new rig giving me steady max fps, mouse issues defo unrelated to performance

I improvised a fix using GlovePIE 0.43 (download here)
It's not perfect, but it made the game actually playable for me
1. It fixes the inconsistency between horizontal & vertical speed
2. Xenus lowers speed of fast swipes, so I made fast swipes go slightly faster

Setup
It was made for a specific resolution & mouse sensitivity, so will probably need to tweak
1. Note when the negative mouse lag thing kicks in when you swipe.
2. Open up glove pie, uncomment the debug line and immitate the mouse motion
3. Note the number and change var.swipeSpeed a bit lower than that.
4. Test ingame, and comment line when you're done.

Code:

// Xenus2 fix for slow horizontal movement & negative accel on fast swipes
// For 2560x1440, using Mouse Sensitivity=0.000230

var.swipeSpeed = 50      // tweak this
Pie.MouseDPI = 800
Pie.FrameRate = 60

//debug = delta(RealMouse.DirectInputX)  // Use this to get mouse speed, to check at which point xenus kicks in the mouse lag
var.dX = delta(RealMouse.DirectInputX)
if (abs(var.dx) > 50)
  var.fix = var.dX * 2
  FakeMouse.DirectInputX += var.fix
}

FakeMouse.DirectInputX += var.dX*0.7    // Fix horizontal/vertical inconsistency



All times are GMT +2. The time now is 04:27.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch