RPGWatch Forums

RPGWatch Forums (http://www.rpgwatch.com/forums/index.php)
-   Tech Help (http://www.rpgwatch.com/forums/forumdisplay.php?f=25)
-   -   "device driver has stopped working but has recovered" error (http://www.rpgwatch.com/forums/showthread.php?t=21091)

Nerevarine July 8th, 2013 08:40

"device driver has stopped working but has recovered" error
 
Hello again fellow watchers, I find myself in need of some assistance once again, and any help would be greatly appreciated. First, a bit of background:

As mentioned in the "Graphics card upgrade suggestions" thread, I have been in the process of upgrading my PC. One of the necessary steps was to upgrade to Windows 7 64 bit - I used to have a dual-boot setup with both XP and 7, but my old hard-drive crashed and I decided to just run XP, thinking that it would get me through for a few years until it was no longer supported or wouldn't work with, say, a new graphics card, newer games, or more ram.

Fast forward to now, and the time has finally come to upgrade to Windows 7 permanently. I completed the upgrade process a little less than a week ago, and proceeded to install the latest drivers for my current card (ATI 5850).

Unfortunately, this is where the trouble started: When browsing the web, my machine seems to lock up, with the screen going black for a few seconds and then returning with the error message: "The display driver has stopped working but has recovered." Sometimes it won't recover at all, and my machine crashes to the blue screen before rebooting.

This problem is extremely frequent, usually occurring at least once every time I browse the web (firefox is my default browser.) Here is the strange part: I tested to see if this issue occurs with gaming by playing Dishonered (great game by the way ;)). I am able to run the game in medium settings without suffering any lag or fps drops, and I've only had this same error occur two or three times in about 10 hours of gameplay. So it does seem to occur during gaming, but not as frequently as simple web-browsing, and it has recovered the few times that it has happened rather than outright crashing to a blue screen and rebooting.

Here are the solutions I have tried to solve this issue:
1.) Install latest graphics card drivers.
2.) Install a few miscellaneous drivers for the motherboard
3.) Change Windows 7's default power settings to high performance
4.) Adjust the timeout detection and recovery registry values

I am truly at my wits end, and I'm baffled because this problem NEVER occurred when my system was still on Windows XP less than a week ago - it all started when I upgraded to Windows 7. Because you cannot directly upgrade from Windows XP to 7, it was a "clean install" as well. Any help or advice would be greatly appreciated!

PS: here are my system specs if it's any help:

CPU: AMD Phenom II x4 965
Graphics Card: Radeon 5850
Motherboard: Gigabyte GA-870A-UD3
OS: Windows 7 64 bit
Ram: Corsair 4GB (2x2)

Drithius July 8th, 2013 08:59

Was XP previously 32 or 64bit? If 32, you could have some older hardware conflicting with your new 64bit architecture. Perhaps an old NIC or soundcard?

Failing that, have you tried a different driver version for the video card?

Icefire July 8th, 2013 09:18

http://support.microsoft.com/kb/2665946

See if that is of any help.

Nerevarine July 8th, 2013 10:23

Quote:

Originally Posted by Drithius (Post 1061206595)
Was XP previously 32 or 64bit? If 32, you could have some older hardware conflicting with your new 64bit architecture. Perhaps an old NIC or soundcard?

Failing that, have you tried a different driver version for the video card?

I had a 32-bit version of Windows XP installed. I checked the NIC (Realtek PCIe GBE family controller), and it appears to be compatible with Windows 7 64-bit. For sound card, I seem to have two listed in my device manager: AMD High Def. Audio Device and Realtek High Definition Audio…I'm guessing the Realtek is my actual sound card. They should be compatible with Windows 7 64-bit as well. My system is "new" enough that all the hardware should be compatible.

I haven't yet attempted rolling back my graphics card drivers to older versions…perhaps that is something to consider.

Thank you for the quick response Drithius!

Icefire: Thank you for the link, unfortunately I found that on my own and the solutions didn't work (that was where I found how to edit the timeout detection and recovery registry values, and sadly, it didn't solve the problem). Thanks anyway though, I appreciate the help!

Icefire July 8th, 2013 10:53

I thought you might have found that already. But I figured it wouldn't hurt just in case. And I thought you had already tried rolling back the driver. That should have been the first thing you tried. Roll that puppy back!

joxer July 8th, 2013 10:59

MoBo and etc drivers?
Try with this:
https://www.slimwareutilities.com/slimdrivers.php

Alrik Fassbauer July 8th, 2013 13:23

I've had this error a *lot* of times when I was playing DDO with my Radeon card.
I still don't know why this is.

Maylander July 8th, 2013 14:03

This error can be cause by quite a few different issues actually. In my case it was a simple matter of the GPU being a bit too strong for the games I was playing, so it ended up going into idle mode and Win 7 decided it would be a brilliant move to swap to the integrated Intel GPU. I hate those things, they've caused so much trouble for me. If only there was a way for Windows to never even take the damn thing into consideration.

Anyway, the solution for me was to manually increase the idle GPU speed so it was always considered active. The idle speed is usually set to 157/300, and I think I pretty much doubled that. However, it's a simple matter of experimenting - you want it set high enough to never get the error, but not so high it'll grow hot or become too loud.

Nerevarine July 8th, 2013 23:39

Quote:

Originally Posted by Maylander (Post 1061206624)
This error can be cause by quite a few different issues actually. In my case it was a simple matter of the GPU being a bit too strong for the games I was playing, so it ended up going into idle mode and Win 7 decided it would be a brilliant move to swap to the integrated Intel GPU. I hate those things, they've caused so much trouble for me. If only there was a way for Windows to never even take the damn thing into consideration.

Anyway, the solution for me was to manually increase the idle GPU speed so it was always considered active. The idle speed is usually set to 157/300, and I think I pretty much doubled that. However, it's a simple matter of experimenting - you want it set high enough to never get the error, but not so high it'll grow hot or become too loud.

Thank you Maylander, I think this might be the issue! Rummaging around in my control center, my idle speeds are 157/300, just as you said. I would be willing to bet that this is causing the problem. Unfortunately, while I can manually increase high performance clock speeds, I can't seem to edit idle speeds from the control center. The only guide I found on google was for a different/much older version of the control center. If it's not too much trouble, would you mind explaining how you altered this yourself?

edit: I think I figured out how to edit the idle speeds - I created a new preset (used to be called "profile," which is what was throwing me off), and looking at the performance tab in "AMD Vision Engine Control Center," it is displaying higher idle clock speeds. I went from 157/300 to 250/450, and will post again with the results.

edit2: Just got the error again…will try higher idle speed of 350/600.

wolfing July 9th, 2013 01:42

do this. In Firefox, go to options -> advanced and uncheck "use hardware acceleration when available"

Nerevarine July 14th, 2013 07:12

Just an update to those kind enough to offer their assistance: It appears after several days of running my GPU with adjusted idle clocks, the problem has ceased occurring. I was a little worried that something else was wrong with my setup when I experienced crashes on loading screens while playing Sleeping Dogs, but this is actually quite a common problem with ATI cards and this particular game. After finding a fix for that, I have had no issues whatsoever.

So thanks again to Maylander for leading me to the solution, and thank you to everyone else for contributing assistance as well! This type of communication and help separates RPGWatch from other PC gaming-focused communities, and I really appreciate it.

Maylander July 15th, 2013 10:58

Happy to help, and glad it worked out. :)


All times are GMT +2. The time now is 05:03.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch