View Single Post

Default Gothic 1 starting problems (not Nvidia related)

January 26th, 2011, 18:09
Decided to install Gothic 1 again and give it a whirl on my new(ish) PC, but my plans hit a snag. The darn thing won't launch without a workaround trick and I decided to ask the esteemed people of the Watch if there could be a better solution to my dilemma. Note that, unlike many posters here with G1 problems, I do NOT have an Nvidia card nor 64-bit Win 7.

What I DO have is Win 7 32-bit and an ATI card. The game installs just fine to version 1.08j right out of the box (I tried 1.08k but it doesn't make any difference). When I try to launch it nothing happens. Program manager shows (under the second tab from the left) that there's a process called gothic.exe running but nothing's happening. I've got G1 set to run in XP compatibility mode and I'm running it as an administrator, but no deal.

The workaround I've found is that if I launch Gothic 1 twice (so I've got two gothic.exe's running), then open the manager and close rundll32.exe, one of the two gothic.exe's shuts down with it but the other launches and I'm able to play Gothic 1 just like I used to on my old PC (I miss the good ol' Win XP). Albeit, I get no intro videos (got sound, but no video). That's no biggie though as the game itself works OK. (I guess I need to disable video scaling to remedy the videos, but haven't gotten around to that yet.)

Has anyone got an idea how I could get G1 to work without that program manager juggling? Even if I can get G1 to run with the workaround, I'd appreciate any help on getting G1 to launch without this trick.

"It is pitch black. You are likely to be eaten by a grue."
Lurking Grue is offline

Lurking Grue

Lurking Grue's Avatar
Random Encounter #23

#1

Join Date: Jan 2008
Location: I come from the land of ice and snow
Posts: 563