View Single Post

Default 

January 27th, 2011, 14:25
I suspect you are running G1 on 1 core - not sure of the best correction method.

Gothic will run on 1 core of a dual core or multi core pc machine - but can possibly crash when the processor goes to high demand, windows control management cannot always cope correctly with sharing 'executions' across the cores - so one way or another they need to be "optimised" .
For example, i have an AMD dual core cpu and have installed the dual core optimiser - there's a nice explanation that goes……

The AMD Dual-Core Optimizer can help improve some PC gaming video performance by compensating for those applications that bypass the Windows API for timing by directly using the RDTSC (Read Time Stamp Counter) instruction. Applications that rely on RDTSC do not benefit from the logic in the operating system to properly account for the affect of power management mechanisms on the rate at which a processor core's Time Stamp Counter (TSC) is incremented. The AMD Dual-Core Optimizer helps to correct the resulting video performance effects or other incorrect timing effects that these applications may experience on dual-core processor systems, by periodically adjusting the core time-stamp-counters, so that they are synchronized.

*G1 is reliant on time stamp counting (RDTSC)* so ideally you would need to find a suitable optimiser software or fix specific to the Intel quad core cpu for your Asus mainboard, it would execute each time the pc is started and be 'invisible' in use. There are also some stand alone optimiser applications though i havn't tried them.

To see what your cores are doing, do your fiddly routine to get G1 running then 'ctrl-escape' to the desktop then 'ctrl-alt-del' into task manager and then observe the multi cpu cores performance graphs prior to any optimisation so you can compare later.

Even in optimised mode with all cores firing, one core always appears to be doing the main work while others are doing less or waiting for higher load demand as required.

Hope this helps a bit.

EDIT (added info) Not sure but you might try some tweeking.

Run 'msconfig' - then to boot options tab/advanced options (check 2 for 2 cores or 4 for four cores) in 'number of processers select tab might yield some results if it isn't set already - but have not tried this myself.
Last edited by Wulf; January 27th, 2011 at 20:01.
Wulf is offline

Wulf

Wulf's Avatar
Inquisitor

#4

Join Date: Oct 2006
Location: North-West England
Posts: 1,106