View Single Post

Default Precursors version?

July 17th, 2013, 18:37
I see Gamers Gate lists Precursors as version 1.1, and that is where I purchased the game. Does that mean I do not need the Russian patch version 1.1? I have the Russian audio files and Wesp patch 1.7 and the game runs - just wondering if it is now the most updated version? Thanks
dogeddie is offline

dogeddie

Traveler

#1

Join Date: Jul 2013
Posts: 2