|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » Games » Deep Shadows Games » The Precursors » Precursors version?

Default Precursors version?

July 17th, 2013, 17:37
I see Gamers Gate lists Precursors as version 1.1, and that is where I purchased the game. Does that mean I do not need the Russian patch version 1.1? I have the Russian audio files and Wesp patch 1.7 and the game runs - just wondering if it is now the most updated version? Thanks
dogeddie is offline

dogeddie

Traveler

#1

Join Date: Jul 2013
Posts: 2

Default 

July 18th, 2013, 09:37
I would guess you don't need the Russian 1.1 patch then…
Wesp5 is offline

Wesp5

Unofficial Patcher

#2

Join Date: Oct 2007
Posts: 407

Default 

July 18th, 2013, 14:16
Thanks Wesp. And thanks for all your work on the game!
dogeddie is offline

dogeddie

Traveler

#3

Join Date: Jul 2013
Posts: 2
RPGWatch Forums » Games » Deep Shadows Games » The Precursors » Precursors version?
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 07:15.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch