|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » Games » Deep Shadows Games » The Precursors » Crash on Quicksave (& Loading it)

Default Crash on Quicksave (& Loading it)

May 13th, 2011, 19:19
Yola,

Just registered to ask about this issue, don't know what's going on. Still in the first city and it crashes whenever I quicksave now. Noticed it after I quicksaved after talking to the Gate Guard about the kid that got abducted into the desert. When trying to load that same save (it shows up in the list), it also crashes. Luckily I was able to make a regular save as a back-up that didn't crash (or crashes on load), because I believe all three quicksave slots are corrupted now.

Here's the dump file, I'm stumped:
Code:
Precursors.exe caused an EXCEPTION_ACCESS_VIOLATION in module vital.dll at 0023:550EA3FA, t_sndengine::NewFrame()+123722 byte(s)

Registers:
EAX=280ED708  EBX=550B3360  ECX=0000001C  EDX=00000000  ESI=280ED698
EDI=4CEE3000  EBP=0018D220  ESP=0018D218  EIP=550EA3FA  FLG=00210212
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

Call stack:
0023:550EA3FA (0x4CEE2FE8 0x280ED680 0x00000088 0x550B3530) vital.dll, t_sndengine::NewFrame()+123722 byte(s)

0023:550B3796 (0x4CEE2FE8 0x280ED680 0x00000088 0x2D580538) vital.dll, store_a()+0022 byte(s)

0023:620C1A3B (0x4CEE2FE8 0x2D580538 0x29DEA058 0x0018D360) game.dll, t_walkunit::save()+0411 byte(s)

[Stack chain broken, lines below can be wrong]

0023:620742D0 (0x00000000 0x00000000 0x00000000 0x00000000) game.dll, t_npc::save()+0016 byte(s)

0023:5509D758 (0x00000000 0x00000000 0x00000000 0x00000000) vital.dll, materialGetType()+0200 byte(s)

0023:5508CD27 (0x00000000 0x00000000 0x00000000 0x00000000) vital.dll, lsmSaveFileLo()+0823 byte(s)

0023:6700B56D (0x00000000 0x00000000 0x00000000 0x00000000) VERender3.dll, DLV_GetInterface()+1773 byte(s)

0023:6704140C (0x00000000 0x00000000 0x00000000 0x00000000) VERender3.dll, IOCompletionCallback()+88892 byte(s)

0023:779EFD35 (0x00000000 0x00000000 0x00000000 0x00000000) ntdll.dll, ZwQueryPerformanceCounter()+0021 byte(s)

0023:77A08841 (0x00000000 0x00000000 0x00000000 0x00000000) ntdll.dll, RtlQueryPerformanceFrequency()+0021 byte(s)

0023:550C94AF (0x00000000 0x00000000 0x00000000 0x00000000) vital.dll, sndUpdateCluster()+0031 byte(s)

0023:44059939 (0x00000000 0x00000000 0x00000000 0x00000000) GFManager.dlv, boost::serialization::singleton<boost::archive::detail::`anonymous namespace'::oserializer_map<VITALENGINE::swapping_binary_oarchive> >::get_instance()+8265 byte(s)

0023:5508CDBC (0x00000000 0x00000000 0x00000000 0x00000000) vital.dll, lsmSaveFile()+0012 byte(s)

0023:62018D40 (0x00000000 0x00000000 0x00000000 0x00000000) game.dll, gameStInit()+5648 byte(s)

0023:6700C475 (0x00000000 0x00000000 0x00000000 0x00000000) VERender3.dll, DLV_GetInterface()+5621 byte(s)

0023:6700F08D (0x00000000 0x00000000 0x00000000 0x00000000) VERender3.dll, DLV_GetInterface()+16909 byte(s)

0023:6700F0AA (0x00000000 0x00000000 0x00000000 0x00000000) VERender3.dll, DLV_GetInterface()+16938 byte(s)

0023:6DD89D2B (0x00000000 0x00000000 0x00000000 0x00000000) d3d9.dll, DebugSetLevel()+463994 byte(s)

0023:6DCF9508 (0x00000000 0x00000000 0x00000000 0x00000000) d3d9.dll, Direct3DCreate9()+166566 byte(s)

0023:630138B3 (0x00000000 0x00000000 0x00000000 0x00000000) DX9RENDER.dll, DLV_GetInterface()+35219 byte(s)
Finally got a nice computer and would like to play it, especially after Wesp's new release that killed that terrible mouse acceleration. Thanks for any help!

Hardware info for troubleshooting:
MS Windows 7 Ultimate 64-bit SP1
AMD Phenom II X6 1090T Thuban 45nm Technology
8.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
MSI 870A-G54 (MS-7599)
Sceptre (1680x1050@60Hz) NVIDIA GeForce GTX 460
The Joe Man is offline

The Joe Man

Traveler

#1

Join Date: May 2011
Posts: 5

Default 

May 14th, 2011, 17:50
Originally Posted by The Joe Man View Post
Still in the first city and it crashes whenever I quicksave now.
Do normal saves work? The game uses the Shared Documents folder for saving, so you might have an issue there…
Wesp5 is offline

Wesp5

Unofficial Patcher

#2

Join Date: Oct 2007
Posts: 408

Default 

May 14th, 2011, 20:49
Originally Posted by Wesp5 View Post
Do normal saves work? The game uses the Shared Documents folder for saving, so you might have an issue there…
I went through and changed all folder/file properties to not be "read only," and re-granted full administrator permission. Same issue.

It was fine quicksaving before, the problem just popped up randomly it seems (and continues to annoy me). I'll test with normal saves only. The back-up save I made to test it worked fine.
The Joe Man is offline

The Joe Man

Traveler

#3

Join Date: May 2011
Posts: 5

Default 

May 14th, 2011, 21:31
Shit, regular saves crash/corrupt it too. The only one that works now is my Back-Up. Gonna try a full uninstall/reinstall to re-populate the shared folder with new files. Bleghhh
The Joe Man is offline

The Joe Man

Traveler

#4

Join Date: May 2011
Posts: 5

Default 

May 18th, 2011, 22:44
Guessing that was the issue; only 1 crash so far, and it wasn't on a QS/QL. My guess is that the old .ini files in the Shared Folder didn't get overwritten and there was a conflict between them and the updated game files.

No idea, though.
The Joe Man is offline

The Joe Man

Traveler

#5

Join Date: May 2011
Posts: 5

Default 

May 25th, 2012, 23:16
I know it's a dead thread, but…

I have the same problem… I have Win 7 x64 too, so I think this may be a OS incompatibility (The game it's designed for WinXP x32)
Triodo is offline

Triodo

Traveler

#6

Join Date: May 2012
Location: Andalucía, SPAIN
Posts: 2

Default 

May 27th, 2012, 10:56
I had the same problem. Initially it happened only occasionally, but after a while it got where every time I tried to save it would crash the game. Those saves of course wouldn't load either. Quite frustrating. What seems to have fixed it for me: going off-world for a bit. To do that I focused on the primary missions until I got the one where you're supposed to get a package from a pilot at the spaceport, who then says that the package is still on another planet and asks you to go get it. I went on to the tago-infested planet and the problem went away after that.

I've since cleared all of the minor missions I could find on the first planet, with only a single similar crash happening a few hours of play after the first spate of them. Thankfully no more crashes since that last isolated one, so… fingers crossed.
Brettflan is offline

Brettflan

Brettflan's Avatar
Traveler

#7

Join Date: May 2012
Posts: 2

Default 

May 28th, 2012, 10:30
I'm getting the same issue "Precursors.exe caused an EXCEPTION_ACCESS_VIOLATION in module vital.dll at 0023:550EA3FA, t_sndengine::NewFrame()+123722 byte(s)"

This "sndengine"…

May SND means SOUND?

If any other has the same issue, please, tell if you are in Win7 x64 or what OS you have

Sorry for my bad English
Triodo is offline

Triodo

Traveler

#8

Join Date: May 2012
Location: Andalucía, SPAIN
Posts: 2

Default 

May 28th, 2012, 20:44
I'm on Windows 7 x64, and the apparent fix for me is posted just above.
Brettflan is offline

Brettflan

Brettflan's Avatar
Traveler

#9

Join Date: May 2012
Posts: 2
RPGWatch Forums » Games » Deep Shadows Games » The Precursors » Crash on Quicksave (& Loading it)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 13:19.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch