|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » Games » Gothic 3 » Gothic 1/2 » Gothic 2 NOTR under vista 64

Default Gothic 2 NOTR under vista 64

June 5th, 2009, 18:34
hey guys
saw that the mod Valeya story of a warrior came out in English, and it jacked me up to play G2 again, I got a new system which runs on vista 64 and although installation went smoothly.
there is no speech!, I can select an option on what to say, and then it instantly comes back to the dialog select screen, without the nameless hero or Xardas(this is as far as I got) say anything!.
I've already put Gothic 2 to run as administrator and in compatibility mode of XP with SP2. and I still get it to work. I'm so sad right now.
any ideas are welcomed!
thanks!

"Yrden, trap it with a Yrden!"
"YOU COME DOWN HERE AND TRAP IT!"
lol gotta love Geralt
cptmaxon is offline

cptmaxon

cptmaxon's Avatar
Watchdog

#1

Join Date: Nov 2006
Posts: 145

Default 

June 5th, 2009, 18:40
I don't have Vista but you might want to check out the GOG edition. It's on sale for $7.49 and it's DRM free and may be more compatible. Also, their support is great - might be worth looking into.
fragonard is offline

fragonard

Watchdog

#2

Join Date: Oct 2006
Location: San Diego
Posts: 196

Default 

June 5th, 2009, 19:12
Try disabling your anti-virus.
Kostas is offline

Kostas

Kostas's Avatar
Dormant Watcher

#3

Join Date: Aug 2008
Location: Dear Green Place
Posts: 1,648

Default 

June 5th, 2009, 21:39
fragonard if I buy GOG version it will the third time of me buying gothic 2 lol, once when it came out, second time when NOTR came out but only sold in the gold edition, does GOG offer downloads?
I'll try disabling my AV thanks Kostaz

"Yrden, trap it with a Yrden!"
"YOU COME DOWN HERE AND TRAP IT!"
lol gotta love Geralt
cptmaxon is offline

cptmaxon

cptmaxon's Avatar
Watchdog

#4

Join Date: Nov 2006
Posts: 145

Default 

June 5th, 2009, 22:46
Yes, GOG is DL only but you can DL as many times as you want. I've bought both Gothic 1 & 2 there. Just not having to have the CD in the drive is almost worth it to me.
http://www.gog.com/en/frontpage/
fragonard is offline

fragonard

Watchdog

#5

Join Date: Oct 2006
Location: San Diego
Posts: 196

Default Tips and Tricks

September 27th, 2009, 22:04
I had lot of problems with Gothic 2 in Win7 (x86), but finally get it working perfectly. No need to run it as admistrator or in compatibility mode.

Here's what I did:

Required steps:
1. Installed Game (Gold == Original + NoTR) all 4 CDs.

2. Installed gothic2_fix-2.6.0.0-rev1.exe.

3. Installed gothic2_vdfs-patch.exe.

4. Installed Community Patch v1.0a (fixes Widescreen and lot of bugs!)

5. Disabled video scaling because my videos only had audio! (system/gothic2.ini):
scaleVideos=0

Optional INI tweaks: (Might not work for all!)

6. Better textures Sumpfis Texture Patch v1.0

7. Ini Tweaks

- Custom resolution (system/gothic2.ini file):
zVidResFullscreenX=1680
zVidResFullscreenY=1050
zVidResFullscreenBPP=32
extendedMenu=1

- Antialiasing, anisotropic filtering and other graphic candy:
zTexAnisotropicFiltering=1
zVidEnableAntiAliasing=1
zSubdivSurfacesEnabled=1
zCloudShadowScale=1
zTexCacheSizeMaxBytes=128000000
zSndCacheSizeMaxBytes=80000000

- Quick Save (F5 save, F9 load):
useQuickSaveKeys=1

- Shortcuts for healing- and mana potions (appears in ingame settings):
usePotionKeys=1

- Harder pick locks (no more cheating by loading the savegame!):
pickLockScramble=1

- Adds more audio providers (like Dolby Surround):
extendedProviders=1

- More blood (bleeding):
bloodDetail=3

- No intro videos:
playLogoVideos=0


Welcome to Khorinis… adventure awaits!

PS. Most of the patches/mods are german, but they don't affect to actual game localization.
Last edited by Ergonpandilus; May 17th, 2010 at 02:18.
Ergonpandilus is offline

Ergonpandilus

Ergonpandilus's Avatar
The Guardian

#6

Join Date: Mar 2009
Location: Oulu, Finland
Posts: 486

Default 

September 28th, 2009, 07:06
PS. Most of the patches/mods are german, but they don't affect to actual game localization.
Cool, I will check that out soon on my polish version and Windows 7. I'll write if it works or not.
Konjad is offline

Konjad

Konjad's Avatar
Watch traitor from Codex

#7

Join Date: Jun 2008
Posts: 712

Default 

October 1st, 2009, 08:43
It didn't help me I have graphic issues as I had before. I guess old Gothics won't ever work on 64-bit systems.

BTW be careful when you install things from Ergonpandilus links. After installing them I had german menus, english subtitles and polish dubbing
Konjad is offline

Konjad

Konjad's Avatar
Watch traitor from Codex

#8

Join Date: Jun 2008
Posts: 712

Default 

October 1st, 2009, 08:56
Originally Posted by Konjad View Post
It didn't help me I have graphic issues as I had before. I guess old Gothics won't ever work on 64-bit systems.

BTW be careful when you install things from Ergonpandilus links. After installing them I had german menus, english subtitles and polish dubbing
I guess then it won't work in x64, but atleast on x86 it works perfectly.

That language this is not true! The whole game is in english for me. Just check gothic.ini that you have the language settings properly. Only thing you will have in german are the installers of the patches/mods. But it does NOT affect to the game.
Ergonpandilus is offline

Ergonpandilus

Ergonpandilus's Avatar
The Guardian

#9

Join Date: Mar 2009
Location: Oulu, Finland
Posts: 486

Default 

October 1st, 2009, 09:42
Whatever, I just uninstalled the game But it doesn't matter for me if the game is unplayable. I wouldn't have the all-english version because I have polish so even if everything else is translated to english, I'd have polish dubbing until I'd have replaced it with english files. Thanks for trying to help anyway, I appriciate it.

EDIT:
BTW. I wouldn't want to change everything to english anyway since polish version is much better in my opinion
Konjad is offline

Konjad

Konjad's Avatar
Watch traitor from Codex

#10

Join Date: Jun 2008
Posts: 712

Default 

October 8th, 2009, 21:40
I´m running this game on Windows 7 (64x edition) with an x64 AMD 6000+ /8600GTS, so it´s working with x64 based systems. At first after installing the game it wouldn´t start at all, but I followed Ergonpandilus steps and voilá it worked!

I only got the german language with the updates, but the game itself where all in english both menus, text, and speech..
gbg_mogge is offline

gbg_mogge

Traveler

#11

Join Date: Oct 2009
Posts: 1

Default 

October 9th, 2009, 09:07
And you did change the language in gothic.ini-file?

The problem could be the community patch (step 4). Give it a shot WITHOUT it.
Ergonpandilus is offline

Ergonpandilus

Ergonpandilus's Avatar
The Guardian

#12

Join Date: Mar 2009
Location: Oulu, Finland
Posts: 486

Default Please Help

November 1st, 2009, 07:21
Hi! I am trying to get Gothic II to work with Windows 7 and although it starts okay, as soon as I go to leave xardas's tower, my screen turns light blue and I can't see anything. I attempted to use your steps below, but my computer won't let me install the first patch (the install button is grayed out), and it also won't let me install the patch for the textures - but it did allow me to do the other patches - so I'm not sure what is going on.

Please help me figure out how to fix this problem - I'm not a real technical person, but I love playing Gothic and I"m really stuck with this issue!

Oh, I"m not sure if this matters, but I'm using an ASUS laptop.

Thanks for your help!!!

Take Care,
Katie

Originally Posted by Ergonpandilus View Post
I had lot of problems with Gothic 2 in Win7 (x86), but finally get it working perfectly. No need to run it as admistrator or in compatibility mode.

Here's what I did:

Required steps:
1. Installed Game (Gold == Original + NoTR) all 4 CDs.

2. Installed gothic2_vdfs-patch.exe.

3. Installed gothic2_fix-2.6.0.0-rev1.exe.

4. Installed Community Patch v1.0a (fixes Widescreen and lot of bugs!)

5. Disabled video scaling because my videos only had audio! (system/gothic2.ini):
scaleVideos=0

Optional INI tweaks: (Might not work for all!)

6. Better textures Sumpfis Texture Patch v1.0

7. Ini Tweaks

- Custom resolution (system/gothic2.ini file):
zVidResFullscreenX=1680
zVidResFullscreenY=1050
zVidResFullscreenBPP=32
extendedMenu=1

- Antialiasing, anisotropic filtering and other graphic candy:
zTexAnisotropicFiltering=1
zVidEnableAntiAliasing=1
zSubdivSurfacesEnabled=1
zCloudShadowScale=1
zTexCacheSizeMaxBytes=128000000
zSndCacheSizeMaxBytes=80000000

- Quick Save (F5 save, F9 load):
useQuickSaveKeys=1

- Shortcuts for healing- and mana potions (appears in ingame settings):
usePotionKeys=1

- Harder pick locks (no more cheating by loading the savegame!):
pickLockScramble=1

- Adds more audio providers (like Dolby Surround):
extendedProviders=1

- More blood (bleeding):
bloodDetail=3

- No intro videos:
playLogoVideos=0


Welcome to Khorinis… adventure awaits!

PS. Most of the patches/mods are german, but they don't affect to actual game localization.
katiendan is offline

katiendan

Traveler

#13

Join Date: Nov 2009
Posts: 1

Default 

November 2nd, 2009, 16:24
Check the ATI/NVidia workaround settings from INI file.
Ergonpandilus is offline

Ergonpandilus

Ergonpandilus's Avatar
The Guardian

#14

Join Date: Mar 2009
Location: Oulu, Finland
Posts: 486

Default 

February 19th, 2010, 14:49
Sound card mabey?
Last edited by Rawsarrow; February 19th, 2010 at 14:53. Reason: relized i posted on a wrong game
Rawsarrow is offline

Rawsarrow

Rawsarrow's Avatar
Born White, Died Unknown

#15

Join Date: Feb 2010
Location: Califorina
Posts: 58
Send a message via MSN to Rawsarrow

Default 

June 17th, 2010, 23:36
Originally Posted by Ergonpandilus View Post
I had lot of problems with Gothic 2 in Win7 (x86), but finally get it working perfectly. No need to run it as admistrator or in compatibility mode.
I'm having a peculiar problem with Gothic 2 and Win 7 (32 bit). Like you, I was originally unable to get G2 running in Win 7, but following your advice, I finally got it running. However, I'm getting no dialogues! I can hear music, and sound FX, but once I start to talk with an NPC, there is no sound and it just skips the voice-over. I can see my dialogue options, but the nameless hero will not speak the sentences out loud and any replies from the NPCs are just skipped. Anyone have ideas how to fix this problem? I'd really appreciate help, as I'm so close of getting G2 NOTR running, that I'm just itching to play it.

My OS is Windows 7 Home Premium (32 bit), I've got an ATI 5850 graphics card, ASUS P7P55D-E mobo with integrated sound, and Intel i7 860 quad core processor. I've got the GOG version of Gothic 2 Gold and I have installed the patches (items 2,3 and 4 on Ergonpandilus' list) and I've disabled viedo scaling (as I too had the same problem).

I've fiddled with the sound settings in the options, tried this setting and that, but nothing seems to help. I'm at a loss, what could be causing this? Help!!

EDIT: Tried looking for language settings in the INI file, but couldn't find anything even hinting that way. Maybe that's the problem?

"It is pitch black. You are likely to be eaten by a grue."
Lurking Grue is offline

Lurking Grue

Lurking Grue's Avatar
Random Encounter #23

#16

Join Date: Jan 2008
Location: I come from the land of ice and snow
Posts: 562

Default 

June 18th, 2010, 23:25
Sounds a bit tough one, if you enable subtitles are those still coming? There is a newer version of community patch, v2.0 out there if you like to give it a shot.

First thing to do, of course, is try to newer/different soundcard drivers. Though, I hardly believe it would be sound card issue, since the sound fx is coming out as well as music. Maybe one of those patches that I put there is the issue and messes up the language. And try run it in admin, if you still haven't.

PS. There is a fresh fix for nVidia owners! http://forum.worldofplayers.de/forum…d.php?t=832583
Ergonpandilus is offline

Ergonpandilus

Ergonpandilus's Avatar
The Guardian

#17

Join Date: Mar 2009
Location: Oulu, Finland
Posts: 486

Default 

June 19th, 2010, 20:33
I've tried these and they work for me (GTX 285).
coaster is online now

coaster

coaster's Avatar
Utarg of Utarg

#18

Join Date: Aug 2007
Location: Englandland
Posts: 536

Default 

June 20th, 2010, 14:03
Originally Posted by Ergonpandilus View Post
Sounds a bit tough one, if you enable subtitles are those still coming? There is a newer version of community patch, v2.0 out there if you like to give it a shot.
Subtitles won't make a difference as the dialogue just skips over anything the NPCs say - no voice, no subtitles. It just jumps over the NPC dialogue like it wasn't there. SOmewhere along the line the patches changed my NOTR launch window to the German version (so it reads Die Nacht des Raben), but the game itself is in English (menus and narrator/Xardas voice in the beginning). This could be an indication that the language files where messed up somehow. Is there a language setting in the INI file? I can't find one.

Oh well, I'll try reinstalling the game and go with the v2.0 of the community patch (I used the v1.0b). I'll try the game first with the vdsf-patch only, if it won't start, then install the fix 2.6.0.0, and test, then the community patch. I'm a bit sceptic though, but test first, moan later.

P.S: I tried Admin mode and XP compatibility mode already, no help there. Also, my sound drivers are up to date. (And as you said, music and sound FX work just fine, so it shouldn't be a sound driver issue.)

"It is pitch black. You are likely to be eaten by a grue."
Lurking Grue is offline

Lurking Grue

Lurking Grue's Avatar
Random Encounter #23

#19

Join Date: Jan 2008
Location: I come from the land of ice and snow
Posts: 562

Default 

June 20th, 2010, 15:02
You may try this:
http://forum.worldofplayers.de/forum…d.php?t=732368
You need the so-called Report Version of Gothic 2. But note: Due to incompatible naming conventions you will probably have no sound and no subtitles in your original Gothic 2 after installing this patch. To fix this problem do the following:
  • Go to <Your Gothic directory>/_work/data/scripts/content/cutscene
  • Rename the file Ou.dat to Ou.bin
  • Rename the file Ou.lsc to Ou.csl
I hope this helps.
Ondo is offline

Ondo

Traveler

#20

Join Date: Nov 2006
Location: Slovenia
Posts: 18
RPGWatch Forums » Games » Gothic 3 » Gothic 1/2 » Gothic 2 NOTR under vista 64
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 12:57.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch