|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » General Forums » Tech Help » Steam issue on new machine

Default Steam issue on new machine

November 29th, 2013, 18:09
I just built a new Windows 7 machine with Office Professional 2010. I installed the Steam client on it and tried to log in. I got the usual message that it recognized I was on a new machine and that an email with a Steam Guard activation code would be sent to me to be used to gain access to my account. Well, I never got the email. I checked the junk and spam email folders and it was definitely not there. I turned off the junk filter completely, added the appropriate domain to my Safe Senders list, and tried again to no avail. Steam Support says the email was sent but I definitely have not gotten it.

The funny thing is, that when I set up a Steam Support account I did successfully receive an activation email from them. I just can't get the one to allow me into my Steam account. Has anyone else had this problem?

I'm starting to see why some people are really against Steam's DRM. I can't access any of my games right now.
Necrosis is offline

Necrosis

Watcher

#1

Join Date: Jun 2008
Posts: 69

Default 

November 29th, 2013, 18:25
Never had this issue.

Did you try to login on the steam website with you account? Did you try to get support to change the email address to another one so you can get the message?

Also, are you sure you were not hacked?
azarhal is offline

azarhal

SasqWatch
RPGWatch Donor

#2

Join Date: Oct 2007
Posts: 2,408

Default 

November 29th, 2013, 18:26
I had that issue a couple of years ago - I got the mail - but it was several hours after the moment I've requested for it. Didn't contact the support, but it felt odd, waiting for a long time.

Also Win7 machine but no Office on it (I use gmail address for Steam so no need for MS Office Outlook).

Toka Koka
joxer is offline

joxer

joxer's Avatar
The Smoker
RPGWatch Donor

#3

Join Date: Apr 2009
Posts: 5,595

Default 

November 29th, 2013, 19:22
Could it have something to do with the browser ? Or the internet options not allowing it to perform certain things ?

Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius and a lot of courage to move in the opposite direction. (E.F.Schumacher, Economist, Source)
Alrik Fassbauer is offline

Alrik Fassbauer

Alrik Fassbauer's Avatar
TL;DR

#4

Join Date: Nov 2006
Location: Old Europe
Posts: 15,849

Default 

November 29th, 2013, 19:40
Steam's sometimes just really slow at sending through the confirmation codes. It'll come through eventually (though will then likely be out of date and you'll need to request a new one, which will then likely be instant). It's not an issue with your computer or browser.
mogwins is online now

mogwins

mogwins's Avatar
Sentinel

#5

Join Date: Oct 2006
Posts: 287

Default 

November 29th, 2013, 20:11
@azharal: I get "Invalid account" when I try to log in from the website. I've always used the client in the past. Steam support told me to log in to my account and provide a different email address. I was a bit peeved about that, since I had just explained to them that I couldn't log in to my account because I wasn't receiving the Steam Guard email.

@joxer: It's been over 24 hours since I first tried. I've tried at least 6 times between yesterday and today and have not received any Steam Guard email, just one email from Steam support which was quite unhelpful.

Thanks for everyone's help. I'm starting to believe that I've thrown my money away on a bunch of games I won't be able to play.
Necrosis is offline

Necrosis

Watcher

#6

Join Date: Jun 2008
Posts: 69

Default 

November 29th, 2013, 20:21
I've had to wait about a day before now. But the "invalid account" suggests it's something else. Have you changed your Steam user name at all? I've been caught out by that - although it displays your new name everywhere, you have log in with your original name.

If all else fails, contact support. I've found they can take a day or so to reply in the first instance, but are then very helpful.
mogwins is online now

mogwins

mogwins's Avatar
Sentinel

#7

Join Date: Oct 2006
Posts: 287

Default 

November 29th, 2013, 20:36
The "invalid account" suggest the problem is with either the credentials you are using or the account was suspended. Although, the client and the website should return the same error message, they use the same credentials…

How long has it been since you successfully logged into Steam?

At worst, you might want to try the "recovery" steps. If the account was suspended, you'll have to contact Steam Support (again) though.
azarhal is offline

azarhal

SasqWatch
RPGWatch Donor

#8

Join Date: Oct 2007
Posts: 2,408

Default 

December 1st, 2013, 03:49
For the longest time I couldn't log in to my Steam account from the browser. The client worked fine but not from the browser. I think at some point I had a steam forum account and a steam account and when they merged they used the wrong password or something, I don't know. Eventually I finally made it work, resetting my password from the Steam client did the trick (I'm sure I tried that many times before and didn't work, but many months later I tried again and it worked).
wolfing is offline

wolfing

wolfing's Avatar
Wonders what SasqWatch is

#9

Join Date: Sep 2008
Posts: 3,100
RPGWatch Forums » General Forums » Tech Help » Steam issue on new machine
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 18:59.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch