|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » General Forums » Tech Help » Need help with running IWD2

Default Need help with running IWD2

February 10th, 2014, 22:58
After having a blast with IWD + NPC mod, I decided to give another go with IWD2 + NPC project. I did install both the game and mod sometime ago (year or two I think?) and I ran into same problem - game is extremely lagged. I did something back then fix it but now I can't remember what I did. IWD + mod had exact same issue but it was easily fixed by turning on 3D acceleration. I don't think there's 3D acceleration option for IWD2 so I'm stuck

I'm running IWD2 on Win 7, previously ran it on Win XP and had same problem. I'm using NVIDIA currently, previously used Radeon. I will get more spec info once I get home.

Thanks in advance!

BG2 fan girl
BG2: Eowyn & Anomen
IWD: Orhlanna & Korin
ME: Shepard & Garrus
purpleblob is offline

purpleblob

purpleblob's Avatar
Princess

#1

Join Date: Nov 2007
Location: Sydney
Posts: 1,065

Default 

February 11th, 2014, 12:21
I had a similar problem with IWD2 on Win XP, and I solved it by altering settings in the NVIDIA control panel:

1. Open the NVIDIA control panel (should be an icon in your taskbar tray)

2. Click on "3D settings" and then select "Manage 3D Settings"

3. Click on "Program Settings" tab, then click on the "Add" button, and then locate the IWD2.exe program file where you installed IWD2.

4. Set "Threaded optimization" to "Off", and set "Multi-Display/Mixed-GPU acceleration" to "Single display performance mode".

Don't know if this will help in your case, but it did solve my problem. If this doesn't work, you could look for answers at sites like gibberlings3, pocketplane, spellholdstudios or other IE game sites. Other than that you can always try a mad google enquiry - just list as many relevant words as you can and see what comes up (I've had some surprising successes with this method).

Best of luck with solving your problem!
groundhog is offline

groundhog

Traveler

#2

Join Date: Aug 2011
Posts: 10

Default 

February 12th, 2014, 10:25
Thanks a lot! I will try that Hope it works.

BG2 fan girl
BG2: Eowyn & Anomen
IWD: Orhlanna & Korin
ME: Shepard & Garrus
purpleblob is offline

purpleblob

purpleblob's Avatar
Princess

#3

Join Date: Nov 2007
Location: Sydney
Posts: 1,065

Default 

February 12th, 2014, 14:23
I can only suggest trying IWD without whatever mods. If that fails, I'll reinstall it, you'll send me your savegame where it happens and we'll sort it out. But possible problems with 3rd party mods only the author can fix.

When released, IWD had problems with ATI cards for months because of a bug in Catalyst drivers. ATI fixed it later.
Shouldn't behave erroneously on nVidia cards.

Toka Koka
joxer is online now

joxer

joxer's Avatar
The Smoker
RPGWatch Donor

#4

Join Date: Apr 2009
Posts: 6,097

Default 

February 12th, 2014, 22:53
I've already tried running it without the mod and I have same problem - it's definitely not a mod problem. BTW, thanks for the offer, joxer! I ended up playing BG:EE last night, so I haven't changed nvidia configuration yet (what groundhog recommended), will try it out tonight

BG2 fan girl
BG2: Eowyn & Anomen
IWD: Orhlanna & Korin
ME: Shepard & Garrus
purpleblob is offline

purpleblob

purpleblob's Avatar
Princess

#5

Join Date: Nov 2007
Location: Sydney
Posts: 1,065

Default 

February 13th, 2014, 22:34
I tried to modify nvidia settings, and it works much better, although lag is still present. I think this should be fine enough for me to progress, thanks for the help guys!

BG2 fan girl
BG2: Eowyn & Anomen
IWD: Orhlanna & Korin
ME: Shepard & Garrus
purpleblob is offline

purpleblob

purpleblob's Avatar
Princess

#6

Join Date: Nov 2007
Location: Sydney
Posts: 1,065

Default 

February 15th, 2014, 20:22
Originally Posted by purpleblob View Post
I tried to modify nvidia settings, and it works much better, although lag is still present. I think this should be fine enough for me to progress, thanks for the help guys!
I also encountered this terrible lag (in Windows 7) and I found a solution here. After following the instructions the lag completely disappeared.

I hope this will be of help to you.
Asdraguuhl is offline

Asdraguuhl

Asdraguuhl's Avatar
Sentinel

#7

Join Date: Jun 2011
Location: Madrid, Spain
Posts: 398

Default 

February 16th, 2014, 05:08
Yeah I saw that before as well, but I really prefer to fix it without adding extra program on my PC… thanks for the suggestion though! It seems like I have to live with the lag unless I want to install the tool kit thingo. It usually lags when someone talks (black box) or when someone cast spell which makes battle more irritating.

BG2 fan girl
BG2: Eowyn & Anomen
IWD: Orhlanna & Korin
ME: Shepard & Garrus
purpleblob is offline

purpleblob

purpleblob's Avatar
Princess

#8

Join Date: Nov 2007
Location: Sydney
Posts: 1,065

Default 

February 22nd, 2014, 18:24
In case you still need it, I recently run across this fix and thought it might help you.

I'd just like to interject here and point out that I'm not going to say anything to spoil the mood, Chief. I'll just float here and watch. Don't mind me, just sitting here, floating and watching, that's me.
Kostas is offline

Kostas

Kostas's Avatar
Dormant Watcher

#9

Join Date: Aug 2008
Location: Dear Green Place
Posts: 1,648
RPGWatch Forums » General Forums » Tech Help » Need help with running IWD2
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 15:02.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch