|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » Games » General RPG » NWN 2 » NWN 1 stuttering issue

Default NWN 1 stuttering issue

May 16th, 2008, 21:38
I just gave good ol' NWN a peek just to remind myself how much or how little games have evolved since BG2, and it's making my eyes bleed. Basically, it stutters like hell. I've tried the obvious things (compatibility modes, various resolutions, various textures, various AA settings, Googling for "NWN nvidia stutter") but no luck so far. Any ideas about what to try when faffing with the .ini files?

Configuration: Vista x64 SP1, GF8800 GTS/320, 4GB RAM, dual WD Raptor hard disks.

(Not a big deal; I've played it through a couple of times and what with ToB still in the pipeline I think I've had my share of high-level D&D for the time being.)
Prime Junta is offline

Prime Junta

RPGCodex' Little BRO

#1

Join Date: Oct 2006
Posts: 8,540

Default 

May 23rd, 2008, 01:00
See if this helps:

In nVidia Control Panel turn the <<"Extension limit" On>>.
ffbj is offline

ffbj

ffbj's Avatar
Sentinel

#2

Join Date: Dec 2006
Posts: 281
Send a message via Skype™ to ffbj

Default 

May 24th, 2008, 03:36
I'm having the same issue, and my PC is very similar to Prime Junta, except for slightly more memory on my 8800GTS and only a single hard drive. Actually, the stutter is intermittent, and I have no idea why.

What is this "Extension limit" thing, exactly? I ask that because, my control panel being in french, I don't know what to look for exactly. I may even have fiddled with this very setting (I just got that PC and still tweak things here and there), which would explain the intermittence.

I live in my own little world, but it's okay, they know me there.

Dungeon Tales
Dantre is offline

Dantre

Dantre's Avatar
Watchdog

#3

Join Date: Dec 2007
Posts: 113

Default 

May 24th, 2008, 03:58
I had an issue with NWN, i had to turn down all the graphical options to low and then it stopped happening. Then I started turning up all the options till I isolated the problem to one of the sliders (I forget which one).

Favourite RPGs of all time: Wizardry 6, Ultima 7/7.2, Fallout2, Planescape Torment, Baldurs Gate 2+TOB, Jagged Alliance 2, Ravenloft: The stone prophet, Gothic 2, Realms of Arkania:Blade of destiny (not the HD version!!) and Secret of the Silver Blades.
bjon045 is offline

bjon045

bjon045's Avatar
Keeper of the Watch

#4

Join Date: Oct 2006
Location: Sigil
Posts: 939

Default 

May 24th, 2008, 04:32
I had some Texture-Errors with NWN 1 with the current nvidia-drivers, they were gone after I installed the nvidia-Beta-Drivers, maybe that is worth a try ?

The Germans are a cruel race. Their operas last for six hours and they have no word for "fluffy".

Captain Blackadder
Fenris is offline

Fenris

Fenris's Avatar
germanic depressive

#5

Join Date: Oct 2006
Location: Franconia
Posts: 428

Default 

May 25th, 2008, 14:05
No luck with Extension Limit (or any other NWN driver settings) either. Nor does turning everything down and resolution to 800 x 600 have any effect on the stuttering. Trying the beta drivers next…
Prime Junta is offline

Prime Junta

RPGCodex' Little BRO

#6

Join Date: Oct 2006
Posts: 8,540

Default 

May 25th, 2008, 14:56
No luck with the new drivers either. Oh well, it's not like I haven't played it enough already…
Prime Junta is offline

Prime Junta

RPGCodex' Little BRO

#7

Join Date: Oct 2006
Posts: 8,540

Default 

May 26th, 2008, 23:51
I downloaded the really new driver yesterday (WHQL !), so I can't say …

But before that, I had "certain moments", when the game not only stuttered, but stalled ! Completely !

And ir reappeared every time I loaded the savegame i had made at this point !

So I believe this "thing" is "saved" into the savegame as well …

It always occurred seemingly out iof nothing, although I had the slight suspect that it had to do with flames and such … Because I had it several times in the OC when in Neverwinter the character was just going the main entrance out from the prison into the fresh air …

Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius and a lot of courage to move in the opposite direction. (E.F.Schumacher, Economist, Source)
Alrik Fassbauer is offline

Alrik Fassbauer

Alrik Fassbauer's Avatar
TL;DR

#8

Join Date: Nov 2006
Location: Old Europe
Posts: 15,868

Default 

May 27th, 2008, 08:54
Don't rule out your sound settings. I had a lot of stuttering, too, that made me go, "Why would this old game not run 100% fluid on my PC?"

Apparently, something in the hardware sound settings caused it, because when I set it to (I think) software (or something) instead of the EAX crap I usually have problems with, things were smooth again.
Thaurin is offline

Thaurin

SasqWatch

#9

Join Date: Oct 2006
Location: The Netherlands
Posts: 2,396

Default 

May 27th, 2008, 11:46
I have a similar setting…and my game stalled also.
Well, not completly-the framerates dropped to 0,1 FPS!
But always when I went from indoors to outdoors.
Maybe there is something wrong with the skyboxes?
Have to try turning these off and see what happens…
mulsum is offline

mulsum

Traveler

#10

Join Date: May 2008
Posts: 9

Default 

May 27th, 2008, 13:21
Originally Posted by Thaurin View Post
Don't rule out your sound settings.
Possible, but my sound card is an on-board chip by Realtek.

Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius and a lot of courage to move in the opposite direction. (E.F.Schumacher, Economist, Source)
Alrik Fassbauer is offline

Alrik Fassbauer

Alrik Fassbauer's Avatar
TL;DR

#11

Join Date: Nov 2006
Location: Old Europe
Posts: 15,868

Default 

May 27th, 2008, 19:03
Originally Posted by Alrik Fassbauer View Post
Possible, but my sound card is an on-board chip by Realtek.
Mine too. That doesn't make a difference. Realtek on-board chips still support EAX, so the configuration may be set to that or something else and cause problems.
Thaurin is offline

Thaurin

SasqWatch

#12

Join Date: Oct 2006
Location: The Netherlands
Posts: 2,396

Default 

June 2nd, 2008, 01:06
I just wanted to add that my stuttering issue is gone now, or at least it seems to. I have NO idea what I did that caused it. I still have an odd issue with shadows, but I can always deactivate them.

I live in my own little world, but it's okay, they know me there.

Dungeon Tales
Dantre is offline

Dantre

Dantre's Avatar
Watchdog

#13

Join Date: Dec 2007
Posts: 113

Default 

June 3rd, 2008, 09:54
Originally Posted by Dantre View Post
I just wanted to add that my stuttering issue is gone now, or at least it seems to. I have NO idea what I did that caused it. I still have an odd issue with shadows, but I can always deactivate them.
Did you make any changes to your game settings… or your environment settings? If the former, I'd appreciate it if you could PM/post your .ini files; if the latter… well, if you don't remember, you don't remember.

I'll try messing more with the sound settings; see if that helps. It didn't occur to me to do much there.
Prime Junta is offline

Prime Junta

RPGCodex' Little BRO

#14

Join Date: Oct 2006
Posts: 8,540

Default 

June 4th, 2008, 04:00
I didn't fiddled with any game settings, except installing the beta patch, but since I just bought that computer, and then a LCD monitor, I was tweaking things here and there. One of these might have been the cause of the stuttering, but it's difficult to say.

The only thing I did related to sound was install the Creative ALchemy software to activate EAX in NWN, but I doubt that was what caused the stuttering.

Sorry I can't be of more help.

I live in my own little world, but it's okay, they know me there.

Dungeon Tales
Dantre is offline

Dantre

Dantre's Avatar
Watchdog

#15

Join Date: Dec 2007
Posts: 113

Default 

June 4th, 2008, 12:47
The stuttering and stalling issue disappeared for me when I turned threaded-optimizing off in the nvidia 3d-settings.
mulsum is offline

mulsum

Traveler

#16

Join Date: May 2008
Posts: 9

Default 

June 4th, 2008, 17:13
Yay, problem solved! It was the sound, as Thaurin suspected. I had it set to RAD Game Tools whatever; setting it to anything else resolved it. Thanks for the help, everyone!
Prime Junta is offline

Prime Junta

RPGCodex' Little BRO

#17

Join Date: Oct 2006
Posts: 8,540
RPGWatch Forums » Games » General RPG » NWN 2 » NWN 1 stuttering issue
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 13:27.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch