|
Your continuous donations keep RPGWatch running!
RPGWatch Forums » Games » Risen 3 » Risen » Lighting glitches - just me?

Default Lighting glitches - just me?

October 11th, 2009, 22:02
I'm playing the demo through Steam, but I keep getting distracted by lighting problems on various vertexes. Does anyone else get the same thing? Basically at certain camera angles you see the lighting from say a torch colour certain triangles on the floor red, then when you move the view a little the lighting goes back to normal.
kalniel is offline

kalniel

SasqWatch

#1

Join Date: Oct 2006
Posts: 1,877

Default 

October 12th, 2009, 01:12
Originally Posted by kalniel View Post
I'm playing the demo through Steam, but I keep getting distracted by lighting problems on various vertexes. Does anyone else get the same thing? Basically at certain camera angles you see the lighting from say a torch colour certain triangles on the floor red, then when you move the view a little the lighting goes back to normal.
I have not seen this and I'm about 15 hours into the game. So, update your drivers?
matziq is offline

matziq

Watcher

#2

Join Date: Mar 2009
Posts: 49

Default 

October 12th, 2009, 01:32
I also haven't seen this. There aren't many reports about graphics problems. So I assume it's an exception.
Gorath is offline

Gorath

Gorath's Avatar
Prime Evil
RPGWatch Team

#3

Join Date: Aug 2006
Posts: 6,818

Default I think I know what your talking about…

October 12th, 2009, 03:08
Hi there… I think I noticed the same thing… I looked at the water reflections while in a pond and very slightly moved my view a little bit and there was a change in a part of the reflection closer to me… It's no big thing and I think it might have something to do with LOD because it seems to happen (to me at least) with textures that are almost out of view.
The problems that I think are more pronounced are the flickering lighting vegetation and lack of any AA options… other than that this game looks great….

EDIT:
I know you can fiddle with the LOD in the configuration file to show you more of whats in-front of you - so if it is a LOD problem maybe put in three more lines for negative values of the XYZ coordinates - and you probably don't have to put them in such high values as the front view as you only need a little more to cover the sides of the viewspace…I'm sorry for the measly help I can provide you…but I try my best

EDIT#2:
I have pretty basic computer know how but maybe if you disable the caching in the configuration file the textures will not be so…I don't know…dynamic-acting I mean if the caching in and out of textures on the fly is going on aren't there more chances for texture pop-ups and flukes…again it's a long shot and requires a little time and energy…..but that is my help for you…..there goes another happy costumer I believe
Last edited by rockyourazz; October 14th, 2009 at 11:58.
rockyourazz is offline

rockyourazz

Watcher

#4

Join Date: Oct 2009
Posts: 61

Default 

October 12th, 2009, 20:52
Thanks for the replies. Drivers are latest versions, and it does seem like a LOD or possibly AF optimisation problem (which would be at the driver level). Probably curable by fiddling with CCC options.
kalniel is offline

kalniel

SasqWatch

#5

Join Date: Oct 2006
Posts: 1,877
RPGWatch Forums » Games » Risen 3 » Risen » Lighting glitches - just me?
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 00:33.
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright by RPGWatch