RPGWatch Forums

RPGWatch Forums (https://www.rpgwatch.com/forums/index.php)
-   Tech Help (https://www.rpgwatch.com/forums/forumdisplay.php?f=25)
-   -   Why is my Asus soundcard not detected (https://www.rpgwatch.com/forums/showthread.php?t=46758)

a pibbur January 16th, 2021 12:41

Why is my Asus soundcard not detected
 
… by windows 10?

As I said in the 'nut's sound thread: I have an Asus Strix Raid 7.1 soundcard which I'm very happy with when it works. However, most of the time (but not always) it's not detected by Windows 10. I wonder why.

Suggestions (other than buying a new card)?

a pibbur

PS. I suspect it may be a windows problem, because sometimes the Realtek is also not detected properly. Windows insists that it's not connected. By repeatedly plugging in/out my headphones it has so far eventually started working (without rebooting). DS.

EDIT: It has been a well known problem it seems, apparently has something to do with expired digital signatures. New drivers released by Asus 25.12.2020 is supposed to fix the problem. I'll download and see what happens.

Pladio January 16th, 2021 13:55

I was going to say that best thing to do is to uninstall drivers and reinstall the latest ones.

Sent from my SM-G975F using Tapatalk

a pibbur January 16th, 2021 14:53

Quote:

Originally Posted by Pladio (Post 1061629244)
I was going to say that best thing to do is to uninstall drivers and reinstall the latest ones.

Sent from my SM-G975F using Tapatalk

Already did that, no effect. But that was before the 2020 drivers arrived.

Pladio January 16th, 2021 14:53

Sorry that's the extent of my knowledge other than turn your computer off and back on again.

Sent from my SM-G975F using Tapatalk

Drithius January 16th, 2021 16:56

I used to have an Asus sound card - HORRIBLE driver support :p It single-handedly convinced me to go back to Creative Labs.

a pibbur January 16th, 2021 17:43

Quote:

Originally Posted by Drithius (Post 1061629261)
I used to have an Asus sound card - HORRIBLE driver support :p It single-handedly convinced me to go back to Creative Labs.

Yes, they've been very slow to fix the problem, but finally they've released new drivers which is supposed to fix the problem.

If I get it to work again, it's a very good soundcard IMO, but I'm not sure I'll go for an Asus next time.

BTW: I have several Asus motherboards, and one Asus RTX 2080 Ti. I've never had any problems with those thingies.

a pibbur

Drithius January 16th, 2021 19:16

Quote:

Originally Posted by a pibbur (Post 1061629269)
BTW: I have several Asus motherboards, and one Asus RTX 2080 Ti. I've never had any problems with those thingies.

Yes, Asus is always my first choice in motherboards. The sound card foray was an experiment to see if they would be better than Soundblaster - but I felt like I was partaking of some beta program.

a pibbur January 17th, 2021 14:14

Installed the new drivers now, and the soundcard works. We'll see what happens over time, but for now, it works.

an incarnation of pibbur who is now as happy as can be (which in this case means slightly below neutral).

TheRealFluent January 23rd, 2021 05:21

glad it's working for you, pibbs! have fun. :party:

i'm not looking forward to when i install a fresh windows 10 and have to download the drivers for my "obscure" emu sp1212m card again. how i even got that thing working is about a mystery, let alone doing it twice. :) I'll tackle it…someday.


All times are GMT +2. The time now is 10:44.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
vBulletin Security provided by DragonByte Security (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright by RPGWatch