RPGWatch Forums

RPGWatch Forums (https://www.rpgwatch.com/forums/index.php)
-   Risen (https://www.rpgwatch.com/forums/forumdisplay.php?f=34)
-   -   Risen Install Problem (https://www.rpgwatch.com/forums/showthread.php?t=10441)

CrazyIvan April 25th, 2010 17:44

Risen Install Problem
I bought the PC version of Risen from Direct2Drive, which is only relevant because rather than having a CD, all the install files are on my computer.

I am getting C++ errors when trying to install. I believe this is a problem with my computer and not the game…HOWEVER, on other games, I have simply been able to disable the installation of Microsoft C++ redistributable via the various games' ini files, so when they install, they would bypass this step. My computer won't let this program access some of the registry. I don't know why, and after looking through the registry, I can't find the things it is trying to change.

This is the error I get:

So, is there a way to disable the C++ install for Risen? I couldn't find anything on the ini file. If I let it go through, then the game will not start & tells me "side-by-side configuration is incorrect."

I paid $40 for this game, and I'd like to play it. I am peeved because Deep Silver forums are not accepting new registrants, so I can't ask my question there.


Maylander April 26th, 2010 13:41

I've never even seen this problem before. Usually when there's an access problem, the solution is to simply run the application as administrator.

That usually generates a different error though, so I'm pretty much clueless. Might try over at World of Gothic/Risen, someone might've encountered it before.

CrazyIvan April 26th, 2010 18:23

I even deleted the entries in the registry, and the program seems to reinstall them, but they immediately become read only, causing the program error.

I have tried running it as administrator as well as running it in compatibility mode of XP. Both methods yield the same result.


Thanks…I'll try your suggestion of the other forum.

Gorath April 26th, 2010 18:34

Really a strange error. WoR is indeed your best chance. The guys over there know quite a lot about the game.

HiddenX April 26th, 2010 20:55



Patrick July 9th, 2010 11:05

The Risen exe file just gets deleted. I tried deleting all quarantined files in Mcafee,turned of Mcaffee, uninstalled Risen and removed the risen folder from the program files, I also removed all files to do with Deep Silver from the registry.
I installed Risen,but when I try running the game it loads the first screen and then crashes to desktop. When I check the Risen folder there is no Risen exe ??
I repeated the above with and without the latest patch with the same result. I have tried running the game in compatible mode,but as there is no Risen exe. I just get an error message that the Targetbox is not valid.

All times are GMT +2. The time now is 05:35.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright by RPGWatch