RPGWatch Forums

RPGWatch Forums (https://www.rpgwatch.com/forums/index.php)
-   General RPG (https://www.rpgwatch.com/forums/forumdisplay.php?f=14)
-   -   Might & Magic X - Can't reach Act 2 (https://www.rpgwatch.com/forums/showthread.php?t=23138)

HiddenX January 26th, 2014 00:42

Might & Magic X - Can't reach Act 2
I have this problem.


I have bought the Early Access-Deluxe-version + boxed version (these are 2 different keys!)

Last week I got the box. After installing the full version I can only play to then end of level 2. Lev dialog is grey and I can't cross the bridgle.

I can't redeem my Code ingame. Message: -> Ubisoft Servers unreachable.

On the other hand UPLAY accepts the Code in the Uplay Starter. I can download the sound files for example.

I don't want to hack game files. Please find a solution for this fast.

I deinstalled Might&Magic X (Early Access version and the Deluxe Version) then reinstalled the Deluxe Version -> same Problem.

joxer January 26th, 2014 01:39

Ubisoft Servers unreachable?
That's the message that plagued me when I was playing M&M6 - and the problem was on their side!

Oh I see you went onto Ubi forum, mhmkay. If anyone can help you, that's the community there.

Corwin January 26th, 2014 05:25

Here's a link which should help.


HiddenX January 26th, 2014 11:51

This was my original link :)

It only describes the problem.

Some early access players can't reach act 2, because the game still thinks you have the early access version.

Reentering the key from the cd-box ingame leads only to "Uplay-servers are not reachable, check your firewall settings".
I disabled the firewall -> same problem.

Two words:
Uplay sucks!

Some Steam-players have the same problem.

Couchpotato January 26th, 2014 12:37

Seems to be a Uplay problem as usual, and it wont be the last time this happens. The funny thing about these problems is Ubisoft never admits the problem is on their side.^^

HiddenX January 26th, 2014 12:40




-> nothing funny about it, I really like the game, supported it from the 1st minute and can't play it …

Couchpotato January 26th, 2014 12:55

Well I can recommend a crack if you want. I know you said you don't want one, but it might be the only way to continue playing. ;)

It wouldn't be my first time using one on a Ubisoft game.:(

HiddenX January 26th, 2014 12:59

I found the solution:

I had to activate automatic UPnP adjustment for security options in my Fritz-Box router.


Then was able to redeem my code ingame

Couchpotato January 26th, 2014 13:03


Originally Posted by HiddenX (Post 1061237803)
I found the solution:

I had to activate automatic UPnP adjustment for security options in my Fritz-Box router.


I hate when it's the simple solution. In the words of homer Simpson.


HiddenX January 26th, 2014 15:07


And I opened these ports in my router: 80, 443, 13000, 14000, 14008

(don't know if this is really neccessary …)

Corwin January 27th, 2014 00:00

I hope you posted that solution back at wonderful Uplay, where I'm sure they will appreciate your assistance!! :)

HerrSchnuff January 30th, 2014 15:39

Even easier solution:

1. Edit this file:

2.Delete all lines with:
condition xsi:type="PrivilegeUnlockedCondition" privilegeID="1001" failState="DISABLED"

3. Enjoy the game

Lev January 30th, 2014 15:53

I'm not sure if it can help, but I think I had something like this in the release day. When I launched the game via Steam it forwarded me to the Early Access version of game. I did it several times, I restarted Steam, rebooted PC, nothing helped.
Then I've just went to program folder (I don't remember if it was in "Program Files" folder or if it was in "Steam applications" folder) and launched Might & Magic X executable. And the problem was magically solved for me.

crpgnut January 30th, 2014 17:17

Lev all you have to do to fix the issue is to talk to HiddenX when he comes up to ride your Griffin. Problem solved!

Lev January 30th, 2014 17:46

I don't even have a Griffin :)

All times are GMT +2. The time now is 04:43.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright by RPGWatch