RPGWatch Forums

RPGWatch Forums (https://www.rpgwatch.com/forums/index.php)
-   NWN 2 (https://www.rpgwatch.com/forums/forumdisplay.php?f=23)
-   -   Repeating cheats issue? (https://www.rpgwatch.com/forums/showthread.php?t=3926)

Nyshano February 19th, 2008 11:39

Repeating cheats issue?
No real spoilers in this post, but if you're particularly worried about them, you may not want to follow the link. It also sounded a lot less whiny while I was writing it.. apologies.

I've just gotten to the Neverwinter archives, about four missions short of Chapter 2 (sod's law, yay!), and my quest is stuck - I can't see the riddle books (yep, I'm using the appropriate item on the appropriate char). Google told me that this issue has been reported before, and can be fixed by updating the quest using a cheat, namely "rs 16_a_puzzle_update" (can't find where I actually learned that, but this thread at Bioware says the same).
The cheat works once, and I get to "you have answered 1 question, now do three more"; aaand then the cheat stops working. The console reports a success, my character glows and makes a dinging noise, and the quest stays stuck 1/4 of the way through.
I'm currently on v.1.10.1115, and not too enamoured with the idea of updating, as I did so a few days ago and then had to reinstall in order to be able to play again. I've tried exiting and reentering debug mode and the game, and loading from a slightly earlier save. Have I just missed something glaringly obvious here (wouldn't be unlike me), or do I actually have a legitimate problem? And if so, anyone know how to fix it?

And while I'm here - if being a greedy little bugger I happened to keep a certain sacred dwarven artefact, have I borked the related quest forever? :D

Sorry about the huge great "help me!!!!!" here…
-Someone well practised at ambiguity

jmurdock February 20th, 2008 19:07

That happened to me when I installed MotB. None of the item scripts worked. You can run the Item script for the helmet in debug mode in the console. I don't have the name handy, but will look it up for you later.

Nyshano February 28th, 2008 17:32

Ah, a somewhat related question… in the cheat above, it seems that 16_a_puzzle is an id for either the quest or the quest step. Does anyone know where I can get my hands on a full list of these? After screwing that character up royally, I started anew - and already the retrieval of the shard from the lizardlings is stuck. I get the feeling I'll be using this method lots. :P

jmurdock February 28th, 2008 22:08

It doesn't work for some items either. Let me look at how I fixed it and see if I can help you fix yours.

jmurdock March 4th, 2008 21:10

First thing you do is save the nwn2 directory to a second location, just in case something goes wrong. ok, you need to open the toolset and one of the modules. they are all in the modules subfolder. open up x2_inc_switches.nss. put a space and delete it anywhere in the file. Save and compile. It will tell you it can't save it to the original location. Save it to the module instead. Save the module. That should do it. you will have to start campaign over. If you're not comfortable with this, you will have to uninstall and reinstall the original campaign to play it properly.

All times are GMT +2. The time now is 16:27.

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright by RPGWatch