RPGWatch Forums
Page 1 of 7 1 2 3 Last »

RPGWatch Forums (https://www.rpgwatch.com/forums/index.php)
-   General Non-RPG (https://www.rpgwatch.com/forums/forumdisplay.php?f=26)
-   -   Let's Play Space Quest 1 *picture heavy* (https://www.rpgwatch.com/forums/showthread.php?t=8070)

skavenhorde September 8th, 2009 16:09

Let's Play Space Quest 1 *picture heavy*
That's right boys and girls I'm bringing one of the best thread ideas from the codex over here. Why should they get all the fun?

First things first, this is my first let's play and posting so many pictures at once or even trying to take good screenshots. It was a little more difficult than I thought to take screenshots. I'm using fraps, but even that program has problems sometimes. So I'm switching between the dosbox ctrl-f5 screenshot option and fraps.

A 'Let's Play' thread is a thread where one person plays a game taking screenshots of his/her progress. A normal Let's Play let's the other forum members take part in the progress of the story. Like if I ended at a part of the game where it gave you different paths to follow in the game the forum members would chime in to which way they want you to go. This one isn't that. This one is more like a 'I'll play' since there aren't any choices in this adventure game. I'll just be playing it from start to finish showing you the progress of the game as I go.

The posts are limited to 6 pictures per post so plan on seeing a godly amount of double posting.

If this works out I plan on doing more of these. I started with Space Quest because it's short and I just replayed it about a year ago. It's still fresh in my memory. Plus there are a lot of youngsters out there who have never even seen this classic. I think they're too afraid to type sentences instead of using a mouse to do all their work.

For those of you who have never heard of Space Quest (poor saps) here is what wiki had to say about:
Space Quest is a series of six science fiction computer games that follow the adventures of a hapless janitor named Roger Wilco, as he campaigns through the galaxy for "truth, justice and really clean floors".

Initially created for Sierra On-Line by Mark Crowe and Scott Murphy (who called themselves the "Two Guys from Andromeda"), the games parodied both science fiction properties such as Star Wars and Star Trek, as well as pop-culture phenomena from McDonald's to Microsoft. The series featured a silly sense of humor heavily reliant on puns and wacky storylines. Roger Wilco, a perpetual loser, is often depicted as the underdog who repeatedly saves the universe (often by accident) - only to be either ignored or punished for violating minor regulations in the process.

This game was released in 1986 so don't expect the best graphics out there. Heck you weren't even able to use a mouse back then. You had to type in what you wanted to do (god forbid).

Space Quest 1: The Sarien Encounter (EGA)


The two guys from andromada (I miss those guys)


You're allowed to change your name. Hint: Name inspired from the show Scrubs.

skavenhorde September 8th, 2009 16:16



Through the door on the left and using a command that you will get used to in this game 'look'.


skavenhorde September 8th, 2009 16:25

I'll have to stop here for a few minutes. I just noticed that Fraps cut almost all of the dialogue boxes in half. I'll have to retake those again.

Grandor Dragon September 8th, 2009 16:35

I love Let's Plays. Something Awful has a few that are wonderful:


I don't mean to hijack the thread, but my absolute favorites are the Ultima 4, 5 and 6 LPs by Nakar. Really, check them out, especially if you know the game already!

I think LPs are more enjoyable if there are comments, and they are either very interesting (lot's of background info on design or technology) or just entertaining.

skavenhorde September 8th, 2009 17:07

Ok, Fraps sucks when trying to take screenshots with dialogue boxes. Should of checked all the shots before I took screenshots up to half of the game and uploaded them to photobucket. I'll be using the ctrl-f5 for dialogue box screenshots and fraps for the normal game. The dosbox one takes much smaller screenshots than fraps, but whatcha going to do?

@Grandor Sorry dude, I'm just not that witty. I'll try to liven it up, but seriously you don't want me making jokes. They just suck something awful (pun inteded):-)

Ok here is the continuing adventures of Janitor aka Roger Wilco. Last we left him he just woke up from a catnap in the broom closet. Almost immediatly the alarm sounded and he headed straight into the library. He is now checking out the room he wandered into.

No, not that kind of UNIT.

This kind.

Ok, I think I'm done for now. There is definitely something here, but we have no idea what to get yet. Exit stage right.

Oh cool, everyone is dead. I got dibs on that stargenerator thingamajig.

Let's see if this was a rpg I would be stripping this dead body naked and selling the *phat* loot at the local pawnshop. Let's try that.
What did we learn from this post? Always search any dead body you find. You never know when that keycard or other phat loot will come in handy.

skavenhorde September 8th, 2009 17:39

We head on back to the library. I've got a feeling I'm missing something

The first time I played this game I didn't go back to this room. There is something in this room that is vital to the game. If you don't have it at a certain point in the game then you're basically screwed. How was I supposed to know I could get off this dang ship without having everything I needed. I was only 10.


As you're leaving the room an old geezer decides to come in and ruin your day.

RPG instincts kicking in.

Oh great. He's not dead yet. Gotta wait for him to croak before I get my hands on the mighty codpiece of slaying.

skavenhorde September 8th, 2009 17:51


So now we know the obvious. The ship is under attack. They want the star generator and we need to get the hell out of this place. Oh and something cryptic about an astral body. (It's good to have a dying guy pointing and telling you what to look for when your 10 years old :-)

Here comes the hard part. In parts of this game the parser is extremely picky about what it wants you to type. I tried every combination of 'turn on the computer' before I finally got 'look at the screen'. Who knew the dang thing was already on? It looked off to me.
Not this one.
or this
or this
I could literally fill up about 2 pages of attempts to just use the that console.
Until I typed 'look at screen' Then this popped up
Woo hoo! Time to get my cartridge.

Grandor Dragon September 8th, 2009 17:55


Originally Posted by skavenhorde (Post 1060969598)
@Grandor Sorry dude, I'm just not that witty. I'll try to liven it up, but seriously you don't want me making jokes. They just suck something awful (pun inteded):-)

Hehe, no worries. It is easy for me to sit here and write my thoughts about what makes a good LP. I never tried one myself :) I am following yours, and I am pretty sure you will find your style eventually. Just do whatever you think is fun.

I never finished Space Quest 1, but I played it a fair bit, both the original and the VGA remake.

skavenhorde September 8th, 2009 17:56

I'll stop here for today. I've got a lot of screenshots to redo and a few to clean out of photobucket. I hope you enjoyed this little teaser from Space Quest 1. More adventures of Janitor will be here tomorrow.

Thanks Grandor. I'll throw in some lame jokes to liven it up a bit.

The great thing about doing an LP about Space Quest is that it really is a short game when compared to an RPG. That's why I chose this one. I didn't want to bite off more than I could chew for the first one. Plus Roger rocks :)

At least you'll know what happened to our clumsy janitor by the end of this thread. It's definatly worth passing the game. Although for some reason I've never scored a perfect score.:S

wolfing September 8th, 2009 19:43

*sniff* this brings great memories. Although I played this game in my monocolor amber monitor.
An interesting thing about these games is that many times you actually had to lose (and die) to know what to do next. And besides, some of the death popups were really funny.

Thoth September 8th, 2009 22:50

Hey, really cool Skavenhorde! I've only played SQ4 which was a lot of fun back in the day.

I've gotten into a lot of games by following LP's, they're a lot of fun and really give you a feel for the game.

Jaz September 8th, 2009 23:21

Man, the memories *sigh*! When I last played this game, I played it with a five-year-old (no, not mine).
The girl's out of school now…

JDR13 September 9th, 2009 00:15

Those graphics hurt my eyes…

Gorath September 9th, 2009 01:03


Originally Posted by JDR13 (Post 1060969633)
Those graphics hurt my eyes…

Graphics whore! :devilish::greengrin:

skavenhorde September 9th, 2009 12:02

Alrighty then it's time for the continuing adventures of our hapless hero/janitor, Roger Wilco.

I want to thank whoever fixed the images here, I'm thinking Jaz :-) I noticed while I was at work that they were cut off a little on the right side, but now they're perfect. That makes this a little easier. I was trying to figure out which size they would fit in this thread.

And other good news. I figured out how to use fraps so that it won't cut off the dialogue boxes. It's a little odd, but if I alt-enter after I hit the key to take the shot it won't cut the box in half.

And now back to Roger Wilco. Last we checked on him he was just about to grab the cartridge that the dying scientist pointed to. Now we get to see the flying box unit grab the cartridge and bring it back in awsome EGA detail.

Now that we have the cartidge let's try to get the heck off this ticking timebomb. While searching for a way to get off this tin can I hear some footsteps. Roger being Roger decides to check it out thinking that they're probably more scientists with more cool stuff to grab.

Hey cool! It's V.I.N.CENT from the Black Hole. Maybe I can get his autograph. (First of hopefully many obscure movie references that these young whipper snappers won't understand)

I take it that's a no on the autograph thing?

skavenhorde September 9th, 2009 12:11

Well that's just rude. He could of just said no. He didn't have to blast me and then walk away.

Get used to these screens. Wolfing is right in that there are sometimes hints within the death popups that help you figure out how to stay alive and besides they are always funny :-)

Ok, let's try that again. This time let's avoid the sound of footsteps.

You can also hide behind the elevator when they come. As long as you aren't in their line of sight they will just leave.

Now let's head into that blasted door.

skavenhorde September 9th, 2009 12:29

So this is where the star thingamajigie was stored. It looks like something is definitely missing. Say perhaps one star thingy.

RPG instincts kicking in again.

The suspense is killing me.

Goose egg!

That's it for the phat loot. This is the olden days so a keycard was all they could spare.

This room is a dud. Nothing to nab. Let's try to find the way out now.
This looks promising. An elevator that goes into an area we haven't been yet.
Ugghh, more footsteps and dead bodies. This time we'll just chill in the elevator.

skavenhorde September 9th, 2009 12:47

And he's gone. Good thing these imperial soldier wannabe's can't go farther than a few steps.

Next room with three huge buttons and what could be a control console to the hangar.

Definatly the place I want to be. Just gotta flip a few switches and this janitor is out of this nightmare.

Yes we are again looking at another console. That 'look' command was mighty powerful back then. You actually had to use your imagination a little bit.

It couldn't be any simpler than two buttons labled 'open bay door' and 'close bay door'. They must have a lot of technicians in the future that don't know what all the buttons do.

Open sesame.

skavenhorde September 9th, 2009 13:17

In the next area to the right we find an elevator that won't open. I wonder why? Could it have something to do with that panal to the left that looks like it's missing a card shaped object?

Now we see that searching dead bodies pays off.

Looks like we're getting somewhere. I wonder what's in those two doors?

You can't just type 'push button'. It makes you type in which one you want to push. We'll skip past that exciting part and just show you what's behind door #1 and #2. It looks like a cool grey suit and some kind futuristic bong.

Where your character is in the game matters to what kind of description you get. Like when I typed 'look in closet' I was standing near the left one so it gave me the description for the left. When I went to the right it described the right.

JDR13 September 9th, 2009 13:22

How long until the mods start complaining about bandwidth usage here? ;)

All times are GMT +2. The time now is 20:35.
Page 1 of 7 1 2 3 Last »

Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright by RPGWatch