RPGWatch Forums - View Single Post - Ergo's AddonPack
View Single Post

Default Help, I can't install it

August 5th, 2011, 09:10
Originally Posted by firebringer View Post
I was having the same problem with the NA version I bought from Amazon. What seems to have worked for me was to move the .bat file and the add on folder ('Ergo's_AddOnPack') to the game's root directory ('Drakensang River of Time') and run the .bat file there (as an administrator). Of course the .bat will still complain that it can't find the registry locations that it is looking for, but it will still install the add on since it can find the necessary folders in it's current location.

As far as I can tell it seems to have worked. I see all the new traits/advantages/disadvantages/etc. in the expert mode of the character creation screen and when I go to 'Options' it shows 'High' instead of 'Up'. Also, I noticed that the bat created the .bak backup files that it was supposed to in the export folder.

The only item that I believe did not get updated was the application icon; I still have the grey Drakensang Eye. I'm guessing this is a result of the .bat not finding the registries it needed. Still, I can live without the icon as long I get the rest of the add on's goodies.

Soooo….hopefully this'll help anyone who downloaded a purchased copy of the game.

I just can't make this work in Windows 7 64-bit with the NA download from Impulse, which is the same path as above, except Drakensang 2, instead of Drakensang ROT. i.e. C:\Program Files (x86)\Indie Games\Drakensang 2

Using regedit, I couldn't find a Registry Entry under HKLM Software except in the
WOW6432Node section, and as was mentioned, the path is entirely different -- there's no DTP -- it's a couple levels down, under Stardock

The fact that I know absolutely nothing about .bat files or .sql files could have something to do with my not being able to make it work. I tried every variation I could think of to edit the .bat file (and since I didn't know what I was doing, there were quite a few -- with or without the quote marks, with or without the last backslash, with % marks where there were spaces, in front of any or all occurrences of set pfad, running from various places within the directory structure). One of these versions did result in backups being made of the db files, but the originals were not overwritten, although I was running as administrator, and I kept getting the message that they couldn't be found . Any chance you could modify the .bat file, or give me VERY explicit instructions on how I modify it? Imagine that I'm your grandmother and I don't know how to run anything more complicated than a toaster (and you won't be far wrong).
Fleisch is offline


Fleisch's Avatar


Join Date: Oct 2006
Posts: 5
Mentioned: 0 Post(s)