RPGWatch Forums - View Single Post - Anyone with experience in PS:T troubleshooting? (SPOILERS)
View Single Post

Default Anyone with experience in PS:T troubleshooting? (SPOILERS)

March 29th, 2013, 04:31
Planescape: Torment has been on my backlog for as long as I can remember being into RPGs. The final push came by realizing that I could play it on my Linux laptop under wine without any work whatsoever and the whole fuss around PS:T generated by the Torment Kickstarter.

I got the game, installed the needed mods/fixpacks according the link provided on the GoG PS:T page and dived into the game. It's safe to say it has been my most novel gaming experience and that I've been more focused on it than any game in the past 3 years.

(Spoilers below)
A bit of background: My experience with the game was completely smooth until I ran into a portal issue in Ravel's maze that didn't allow me to teleport out of it. Thankfully this post/thread suggested removing the "subtitles in cutscenes" mod which solved the problem.

Now for the actual problem: A bit later in the game I ran into another portal issue. After defeating and sparing Trias in the Crust Administration building a portal is created in the room that the fight took place that is supposed to take me back to the Hive. The problem is that upon activating the portal the only thing that happens is that my party members all move to where the portal is but no loadscreen or anything that would indicate actual use of the the portal is initiated.

I found two reports of a problem with that portal on the Spellhold studios forum and on the GoG forum but short of reinstalling the resolution related mods (which didn't work) there is no answer. I posted on the GOG forum but given how old the threads are and the seemingly low activity of the community I'm afraid I won't get an answer.

I wonder if there is any savegame editor or console command that I could use to either move my party to the Hive (and/or trigger any needed event that would put me back on track). I would appreciate any help on the matter or redirections to forums/threads that may be able to help me.

I think there's no need to describe how much I would hate having to restart the game. Oh and before anyone mentions reloading a previous save, my only two current (=usable) saves are the quicksave and the autosave, both present the problem at hand. However given what happened in the Ravel case I suspect it is not a matter of a corrupted savegame.

Apologies for the wall of text.
I'd just like to interject here and point out that I'm not going to say anything to spoil the mood, Chief. I'll just float here and watch. Don't mind me, just sitting here, floating and watching, that's me.
Last edited by Kostas; March 29th, 2013 at 09:17. Reason: typo
Kostas is offline


Kostas's Avatar
Dormant Watcher


Join Date: Aug 2008
Location: Dear Green Place
Posts: 1,713