RPGWatch Forums - View Single Post - "device driver has stopped working but has recovered" error
View Single Post

Default "device driver has stopped working but has recovered" error

July 8th, 2013, 08:40
Hello again fellow watchers, I find myself in need of some assistance once again, and any help would be greatly appreciated. First, a bit of background:

As mentioned in the "Graphics card upgrade suggestions" thread, I have been in the process of upgrading my PC. One of the necessary steps was to upgrade to Windows 7 64 bit - I used to have a dual-boot setup with both XP and 7, but my old hard-drive crashed and I decided to just run XP, thinking that it would get me through for a few years until it was no longer supported or wouldn't work with, say, a new graphics card, newer games, or more ram.

Fast forward to now, and the time has finally come to upgrade to Windows 7 permanently. I completed the upgrade process a little less than a week ago, and proceeded to install the latest drivers for my current card (ATI 5850).

Unfortunately, this is where the trouble started: When browsing the web, my machine seems to lock up, with the screen going black for a few seconds and then returning with the error message: "The display driver has stopped working but has recovered." Sometimes it won't recover at all, and my machine crashes to the blue screen before rebooting.

This problem is extremely frequent, usually occurring at least once every time I browse the web (firefox is my default browser.) Here is the strange part: I tested to see if this issue occurs with gaming by playing Dishonered (great game by the way ). I am able to run the game in medium settings without suffering any lag or fps drops, and I've only had this same error occur two or three times in about 10 hours of gameplay. So it does seem to occur during gaming, but not as frequently as simple web-browsing, and it has recovered the few times that it has happened rather than outright crashing to a blue screen and rebooting.

Here are the solutions I have tried to solve this issue:
1.) Install latest graphics card drivers.
2.) Install a few miscellaneous drivers for the motherboard
3.) Change Windows 7's default power settings to high performance
4.) Adjust the timeout detection and recovery registry values

I am truly at my wits end, and I'm baffled because this problem NEVER occurred when my system was still on Windows XP less than a week ago - it all started when I upgraded to Windows 7. Because you cannot directly upgrade from Windows XP to 7, it was a "clean install" as well. Any help or advice would be greatly appreciated!

PS: here are my system specs if it's any help:

CPU: AMD Phenom II x4 965
Graphics Card: Radeon 5850
Motherboard: Gigabyte GA-870A-UD3
OS: Windows 7 64 bit
Ram: Corsair 4GB (2x2)
Nerevarine is offline


Nerevarine's Avatar
Keeper of the Watch


Join Date: Nov 2010
Posts: 1,030
Mentioned: 0 Post(s)