Why is my Asus soundcard not detected - RPGWatch Forums
|
Your donations keep RPGWatch running!
RPGWatch Forums » General Forums » Tech Help » Why is my Asus soundcard not detected

Default Why is my Asus soundcard not detected

January 16th, 2021, 12:41
… by windows 10?

As I said in the 'nut's sound thread: I have an Asus Strix Raid 7.1 soundcard which I'm very happy with when it works. However, most of the time (but not always) it's not detected by Windows 10. I wonder why.

Suggestions (other than buying a new card)?

a pibbur

PS. I suspect it may be a windows problem, because sometimes the Realtek is also not detected properly. Windows insists that it's not connected. By repeatedly plugging in/out my headphones it has so far eventually started working (without rebooting). DS.

EDIT: It has been a well known problem it seems, apparently has something to do with expired digital signatures. New drivers released by Asus 25.12.2020 is supposed to fix the problem. I'll download and see what happens.
--
Over the mountain watching the watcher
Last edited by a pibbur; January 16th, 2021 at 12:56.
a pibbur is offline

a pibbur

a pibbur's Avatar
Feeling … lonely?

#1

Join Date: Nov 2019
Posts: 469
Mentioned: 17 Post(s)

Default 

January 16th, 2021, 13:55
I was going to say that best thing to do is to uninstall drivers and reinstall the latest ones.

Sent from my SM-G975F using Tapatalk
Pladio is offline

Pladio

Pladio's Avatar
Guardian of Nonsense
Original Sin Donor

#2

Join Date: Nov 2006
Location: Manchester, United Kingdom
Posts: 6,824
Mentioned: 39 Post(s)
Send a message via MSN to Pladio

Default 

January 16th, 2021, 14:53
Originally Posted by Pladio View Post
I was going to say that best thing to do is to uninstall drivers and reinstall the latest ones.

Sent from my SM-G975F using Tapatalk
Already did that, no effect. But that was before the 2020 drivers arrived.
--
Over the mountain watching the watcher
a pibbur is offline

a pibbur

a pibbur's Avatar
Feeling … lonely?

#3

Join Date: Nov 2019
Posts: 469
Mentioned: 17 Post(s)

Default 

January 16th, 2021, 14:53
Sorry that's the extent of my knowledge other than turn your computer off and back on again.

Sent from my SM-G975F using Tapatalk
Pladio is offline

Pladio

Pladio's Avatar
Guardian of Nonsense
Original Sin Donor

#4

Join Date: Nov 2006
Location: Manchester, United Kingdom
Posts: 6,824
Mentioned: 39 Post(s)
Send a message via MSN to Pladio

Default 

January 16th, 2021, 16:56
I used to have an Asus sound card - HORRIBLE driver support It single-handedly convinced me to go back to Creative Labs.
Drithius is offline

Drithius

Drithius's Avatar
Laughing Gnome

#5

Join Date: Nov 2008
Location: Florida, USA
Posts: 5,230
Mentioned: 23 Post(s)

Default 

January 16th, 2021, 17:43
Originally Posted by Drithius View Post
I used to have an Asus sound card - HORRIBLE driver support It single-handedly convinced me to go back to Creative Labs.
Yes, they've been very slow to fix the problem, but finally they've released new drivers which is supposed to fix the problem.

If I get it to work again, it's a very good soundcard IMO, but I'm not sure I'll go for an Asus next time.

BTW: I have several Asus motherboards, and one Asus RTX 2080 Ti. I've never had any problems with those thingies.

a pibbur
--
Over the mountain watching the watcher
a pibbur is offline

a pibbur

a pibbur's Avatar
Feeling … lonely?

#6

Join Date: Nov 2019
Posts: 469
Mentioned: 17 Post(s)

Default 

January 16th, 2021, 19:16
Originally Posted by a pibbur View Post
BTW: I have several Asus motherboards, and one Asus RTX 2080 Ti. I've never had any problems with those thingies.
Yes, Asus is always my first choice in motherboards. The sound card foray was an experiment to see if they would be better than Soundblaster - but I felt like I was partaking of some beta program.
Drithius is offline

Drithius

Drithius's Avatar
Laughing Gnome

#7

Join Date: Nov 2008
Location: Florida, USA
Posts: 5,230
Mentioned: 23 Post(s)

Default 

January 17th, 2021, 14:14
Installed the new drivers now, and the soundcard works. We'll see what happens over time, but for now, it works.

an incarnation of pibbur who is now as happy as can be (which in this case means slightly below neutral).
--
Over the mountain watching the watcher
a pibbur is offline

a pibbur

a pibbur's Avatar
Feeling … lonely?

#8

Join Date: Nov 2019
Posts: 469
Mentioned: 17 Post(s)

Default 

January 23rd, 2021, 05:21
glad it's working for you, pibbs! have fun.

i'm not looking forward to when i install a fresh windows 10 and have to download the drivers for my "obscure" emu sp1212m card again. how i even got that thing working is about a mystery, let alone doing it twice. I'll tackle it…someday.
TheRealFluent is online now

TheRealFluent

TheRealFluent's Avatar
H.O.O. Inquisitor

#9

Join Date: Sep 2018
Posts: 1,516
Mentioned: 25 Post(s)
RPGWatch Forums » General Forums » Tech Help » Why is my Asus soundcard not detected
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 23:26.
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
vBulletin Security provided by DragonByte Security (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
Copyright by RPGWatch